Can't find firefox release notes on mozilla.org

RESOLVED DUPLICATE of bug 689845

Status

www.mozilla.org
General
RESOLVED DUPLICATE of bug 689845
6 years ago
6 years ago

People

(Reporter: l.mai, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:7.0) Gecko/20100101 Firefox/7.0
Build ID: 20110922153450

Steps to reproduce:

I upgraded to Fx 7 and saw that the url bar no longer displays "http://". I wanted to know if that's a bug or a new feature (and if so, what else is new) so I went to http://www.mozilla.org/en-US/firefox/fx/ to read the release notes. I tried a few links but I didn't see "release notes" or "what's new in firefox 7" anywhere.

I then tried the Help menu; it had a "Firefox Help" entry that took me to <http://support.mozilla.com/en-US/home?as=u>. I searched for "release notes" but the first page of results wasn't even close to relevant, so I gave up.


Actual results:

I still don't know where the release notes are.


Expected results:

There should be a link on the firefox root page, or the "Get Firefox" box, or on http://www.mozilla.org/en-US/firefox/features/, or the Firefox Help menu, or the About box, or anywhere, so I can find the damn thing.

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 689845
(Assignee)

Updated

6 years ago
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
(Assignee)

Updated

6 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.