Hitting RELOAD causes loss of POST variables

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: chip, Assigned: pollmann)

Tracking

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.17-21mdk i686; en-US; 0.8) Gecko/20010215
BuildID:    0.8 release

For a dynamically page (generated from CGI/PHP/JSP..), hitting RELOAD will cause
the loss the of the variables.

Reproducible: Always
Steps to Reproduce:
I have created a test case, in http://chip.uhome.net/mozilla_bugs/reload/page1.html

1.Fire up MOzilla, goto the URL above;
2.Try to enter some information, then submit the form, PHP will assembly a page
called page2.php.
3.On the next page (page2.php), you can see the values are transferred;
4.Hit "Reload", the values are disappeared.

Actual Results:  All values is lost.

Expected Results:  the value of the variables should be kept.


This bug won't occur when using the following browsers in Linux (Mandrake 7.2):
- Opera 5.0b6;
- Netscape 4.75
- Lynx 2.8.4dev.8 (24 Aug 2000)

Also, I've checked it against IE 5.0 Under win98, the problem also won't occur.


The HTML code if page1.html can be obtained simply by viewing source code;

Here are the code of page2.php (very simple one):

<html>
 <head>
  <title>Mozilla bug test: form variables page 2</title>
 </head>
 <body>
  $hidden_var1 = <? echo($hidden_var1); ?><br />
  $hidden_var2 = <? echo($hidden_var2); ?><br />
  $text_var1 = <? echo($text_var1); ?><br />
  $text_var2 = <? echo($text_var2); ?><br />
 </body>
</html>

Comment 1

18 years ago
Confirmed
Platform: PC
OS: Linux 2.2.16
Mozilla Build: 2001021408

Marking NEW.
Severity: critical → normal
Status: UNCONFIRMED → NEW
Component: Browser-General → Form Submission
Ever confirmed: true

Comment 2

18 years ago
really moving
Assignee: asa → rods
QA Contact: doronr → vladimire

Comment 3

18 years ago
reassigning
Assignee: rods → pollmann
(Reporter)

Comment 4

18 years ago
Also, the win32 build of 0.8 also suffers by this problem.

Comment 5

18 years ago
*** Bug 70983 has been marked as a duplicate of this bug. ***

Comment 6

18 years ago
I have another example that doesn't involve a RELOAD, but the POST vars are 
nuked anyway:

  http://penguin.epfl.ch/PHP/Reformat/reformat-buggy.html

Try sending a file (for example:  /etc/profile and then hit the SEND File
button)  I enabled debug statements to show the post variables, and they are
all gone.  This page works fine on other browsers.  The PHP source is visible at
  http://penguin.epfl.ch/PHP/index.html

Let me know if I should submit a separate bug report for this problem.  The loss
of POST variables is a really bad problem -- I would mark up the severity of
this problem...

Updated

18 years ago
Target Milestone: --- → Future

Comment 7

18 years ago
I have a case where doing a RELOAD actually fixes some posting problem.
The first time I do a post, some data is wrong or missing.  But if
I back up to the form and make the same changes to the form and post
again, it works, usually.  Sometimes just reloading the form the 
first time I visit it fixes the problem, sometimes not.  

If this sounds like a useful clue, I can probably narrow it down further by
getting debugging info from the server about what was actually posted.

Comment 8

18 years ago
worksforme on winme cvs 20010524
if i do reload the page may be reloaded from cache but the post data is still
there, if i do shift-reload i get a popup warning me it will resend post data.

Comment 9

18 years ago
works for me on build 2001-05-29-08-trunk

Comment 10

18 years ago
works for me on build 2001-05-29-08-trunk
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 11

18 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.