Closed Bug 689914 Opened 10 years ago Closed 10 years ago

memory not freed when returning to start state

Categories

(Firefox :: General, defect)

7 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 668809

People

(Reporter: nigelh747, Unassigned)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0) Gecko/20100101 Firefox/7.0
Build ID: 20110922153450

Steps to reproduce:

Started in safe mode and did about:memory
Went to http://www.bloomberg.com/quickview/
Opened 6 new tabs - just selected stories at random
Closed all the tabs opened - except the about memory
Took the firefox option to clear history for all time
Went to the about:memory page and asked it to free memory


Actual results:

Memory levels were greater than at start


Expected results:

Whilst it may not be possible to get 100% of the memory back, more should have been returned - when normally running the memory with Firefox 7 is now up to 300mb - was up to 800mb with Firefox 6.02 with addons working
Leak is ONLY around 400mb according to Windows Task Manager
The interesting thing is that in the verbose state - after browsing and clearing all caches - according to the facilities available, memory was still allocated to closed tabs for history that had been cleared.  Could it be that the "clear history" does not free the memory?
"Clear history" does not free memory.  In about:memory, "minimize memory usage" does free memory.

If you're seeing compartments for tabs you've closed after minimizing memory usage, then these are likely zombie compartments.  It's very likely these are due to your extensions.  If you can reproduce in safe mode, please file another bug and cc me!  Otherwise, you'll want to try to figure out which extension is leaking and get in touch with the extension author directly.

As is, this bug illustrates a general problem which we're aware of; it's a dupe of bug 668809.  Yes, we should be better about freeing up memory after you close tabs.  But blockers of bug 668809 should illustrate a precise flaw in Firefox and should have a clear path forward.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: MatchStartupMem
(In reply to Justin Lebar [:jlebar] from comment #4)
> "Clear history" does not free memory.  In about:memory, "minimize memory
> usage" does free memory.
> 
> If you're seeing compartments for tabs you've closed after minimizing memory
> usage, then these are likely zombie compartments.  It's very likely these
> are due to your extensions.  If you can reproduce in safe mode, please file
> another bug and cc me!  Otherwise, you'll want to try to figure out which
> extension is leaking and get in touch with the extension author directly.
> 
> As is, this bug illustrates a general problem which we're aware of; it's a
> dupe of bug 668809.  Yes, we should be better about freeing up memory after
> you close tabs.  But blockers of bug 668809 should illustrate a precise flaw
> in Firefox and should have a clear path forward.
> 
> *** This bug has been marked as a duplicate of bug 668809 ***
I did the minimise memory usage and it did not free the memory...
(In reply to Nigel from comment #5)
> (In reply to Justin Lebar [:jlebar] from comment #4)
> > "Clear history" does not free memory.  In about:memory, "minimize memory
> > usage" does free memory.
> > 
> > If you're seeing compartments for tabs you've closed after minimizing memory
> > usage, then these are likely zombie compartments.  It's very likely these
> > are due to your extensions.  If you can reproduce in safe mode, please file
> > another bug and cc me!  Otherwise, you'll want to try to figure out which
> > extension is leaking and get in touch with the extension author directly.
> > 
> > As is, this bug illustrates a general problem which we're aware of; it's a
> > dupe of bug 668809.  Yes, we should be better about freeing up memory after
> > you close tabs.  But blockers of bug 668809 should illustrate a precise flaw
> > in Firefox and should have a clear path forward.
> > 
> > *** This bug has been marked as a duplicate of bug 668809 ***
> I did the minimise memory usage and it did not free the memory...

Found that a large amount of the "memory loss" and the tracking is related to Microsofts HTML5 extension for Media Player with Firefox.  Disable this and the relevant tracking disappears.  Have notified Microsoft of this feature - but have no date as to if and when it will be resolved
You need to log in before you can comment on or make changes to this bug.