Change "Inspect" shortcut to Cmd+Opt+I, Web Console to Cmd+Opt+K (Mac Only)

VERIFIED FIXED in Firefox 10

Status

()

Firefox
Developer Tools
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: rik, Unassigned)

Tracking

({verified-beta})

Trunk
Firefox 11
All
Mac OS X
verified-beta
Points:
---

Firefox Tracking Flags

(firefox10+ verified)

Details

(Whiteboard: [fixed-in-fx-team][qa!])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

6 years ago
Safari, Chrome and Opera uses Cmd+Opt+I to launch their devtools. I think we should match that.

Might be worth changing other shortcuts to replace Shift by Opt also.

Comment 1

6 years ago
> Might be worth changing other shortcuts to replace Shift by Opt also.

Which ones?

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 696759
(Reporter)

Comment 3

6 years ago
I'm gonna reopen this one because it's only about Mac shortcuts.

The other bug says it can't be done because of Windows bindings.

(In reply to Paul Rouget [:paul] from comment #1)
> > Might be worth changing other shortcuts to replace Shift by Opt also.
> 
> Which ones?
Web Console and Error Console currently use Shift.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 4

6 years ago
Created attachment 574111 [details] [diff] [review]
Patch

This changes the Web Console and Inspect tool to use Cmd+Alt shortcuts.

I left out the Error console cause I think it's not gonna be a tool for web developers.
Assignee: nobody → anthony
Status: REOPENED → ASSIGNED
Attachment #574111 - Flags: review?(dcamp)
Comment on attachment 574111 [details] [diff] [review]
Patch

>+#ifdef XP_MACOSX
>+    <key id="key_webConsole" key="&webConsoleCmd.commandkey;" oncommand="HUDConsoleUI.toggleHUD();" modifiers="accel,alt"/>
>+#else
>     <key id="key_webConsole" key="&webConsoleCmd.commandkey;" oncommand="HUDConsoleUI.toggleHUD();" modifiers="accel,shift"/>
>+#endif

     <key id="key_webConsole" key="&webConsoleCmd.commandkey;"
#ifdef XP_MACOSX
          modifiers="accel,alt"
#else
          modifiers="accel,shift"
#endif
          oncommand="HUDConsoleUI.toggleHUD();"/>
(Reporter)

Comment 6

6 years ago
Created attachment 574200 [details] [diff] [review]
Patch v2

Thanks for the comment Dao, fixed.

I've put Dave for the review but I have no idea who I should ask to review.
Attachment #574200 - Flags: review?(dcamp)
(In reply to Anthony Ricaud (:rik) from comment #6)
> Created attachment 574200 [details] [diff] [review] [diff] [details] [review]
> Patch v2
> 
> Thanks for the comment Dao, fixed.
> 
> I've put Dave for the review but I have no idea who I should ask to review.

You could ask any of the fine gentlemen listed in this page:

https://wiki.mozilla.org/Modules/Firefox

Updated

6 years ago
Attachment #574111 - Attachment is obsolete: true
Attachment #574111 - Flags: review?(dcamp)
(Reporter)

Comment 8

6 years ago
Comment on attachment 574200 [details] [diff] [review]
Patch v2

Thanks Panos. Then I guess I should ask Dao.
Attachment #574200 - Flags: review?(dcamp) → review?(dao)

Updated

6 years ago
Attachment #574200 - Flags: review?(dao) → review+
(Reporter)

Updated

6 years ago
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/192f8762963f
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
Updating the summary to reflect reality.

This may severely impact people's muscle memory.
Summary: Change "Inspect" shortcut to Cmd+Opt+I → Change "Inspect" shortcut to Cmd+Opt+I, Web Console to Cmd+Opt+K (Mac Only)
https://hg.mozilla.org/mozilla-central/rev/192f8762963f
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 11
tracking-firefox10: --- → ?
Comment on attachment 574200 [details] [diff] [review]
Patch v2

Since this changes the key for a new feature, we should land this in aurora to get people used to it.

The webconsole key-binding should be considered a companion setting.

Low-risk. No code changes.
Attachment #574200 - Flags: approval-mozilla-aurora?

Comment 13

6 years ago
[triage comment]
Is there any downside to supporting both the current and this shortcut for web console? Hasn't web console shipped with that shortcut in multiple releases, and wouldn't we be breaking muscle memory that way?
Keywords: #relman/triage/needs-info
(In reply to Christian Legnitto [:LegNeato] from comment #13)
> [triage comment]
> Is there any downside to supporting both the current and this shortcut for
> web console? Hasn't web console shipped with that shortcut in multiple
> releases, and wouldn't we be breaking muscle memory that way?

like, having two shortcuts assigned for the web console? Only downside is some untested xul.

It does break muscle memory, and in some cases, interferes with other shortcuts requiring users to reconfigure hotkeys outside of Firefox (in my case, OmniFocus).

Updated

6 years ago
Attachment #574200 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Did you test that this doesn't break existing localized shortcuts in localizations? (I don't think we have anything better than tweaking a mozmill l10n test and run through all localized builds.)
uh, no, I have no idea how to test that.

I filed a follow-up bug to this: bug 706204 to restore the original web console shortcut as per legneato's comment 13. I'd like to get that into aurora at the same time.
(Reporter)

Comment 17

5 years ago
I just received an email asking me to land this on Aurora. Since I cannot do that, de-assigning myself.

Can someone take it?
Assignee: anthony → nobody

Comment 18

5 years ago
I will land that tomorrow.

Comment 19

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/fadc2aa37e9f
status-firefox10: --- → fixed
Whiteboard: [fixed-in-fx-team] → [fixed-in-fx-team][qa+]

Comment 20

5 years ago
I have tried this on:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:10.0) Gecko/20100101 Firefox/10.0 beta 2
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0) Gecko/20100101 Firefox/10.0 beta 2

Cmd+Opt+I opens "Inspect" and Cmd+Opt+K opens "Web Console"

Setting resolution to Verified Fixed
Status: RESOLVED → VERIFIED
status-firefox10: fixed → verified
Keywords: verified-beta
Whiteboard: [fixed-in-fx-team][qa+] → [fixed-in-fx-team][qa!]

Updated

5 years ago
tracking-firefox10: ? → +
You need to log in before you can comment on or make changes to this bug.