File Bookmark dialog window has gotten wider than my screen. Not resizable

RESOLVED WORKSFORME

Status

SeaMonkey
Bookmarks & History
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: mike, Unassigned)

Tracking

SeaMonkey 2.3 Branch
x86_64
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:6.0.2) Gecko/20110902 Firefox/6.0.2 SeaMonkey/2.3.3
Build ID: 20110902180055

Steps to reproduce:

Open "Bookmarks" in toolbar, select "File Bookmark..."


Actual results:

My "File Bookmark" dialog window has started getting wider.  It is now wider than my
screen.  I can't resize it.


Expected results:

It should allow resizing and remember the last size selection
Mozilla/5.0 (X11; Linux x86_64; rv:10.0a1) Gecko/20110928 Firefox/10.0a1 SeaMonkey/2.7a1 ID:20110928003003

On SeaMonkey 2.7a1 for Linux64, the "File Bookmark" dialog is just as wide as my screen (1024px). I can resize it, and I can move it partly out of the screen by dragging the titlebar.
Component: General → Bookmarks & History
QA Contact: general → bookmarks
P.S. ...and it does remember its size next time I open it.
(Reporter)

Comment 3

6 years ago
Curious, I'm running SeaMonkey 2.3.3 on Windows Vista Home premium and the edges hang off both sides.  I've got a screen cap but it's not obvious if I can attach it here....  
The Dialog started in an earlier version of SM as a nice compact size which opened the entire bookmark tree that was easy to scroll through and identify.  One of the later versions changed to this compressed form that started getting wider and wider until it went off the sides of my screen.  

I didn't really notice how much it jumped each time or under what conditions it changed.  I just noticed that at some point I had to slide it sideways to get at the "Save" Button.  That's when I realized that I couldn't resize it either...

Comment 4

6 years ago
@Tony, you're looking at File Bookmarks, Ctrl+D (& not Bookmarks Manager, Ctrl+B)?


The only way I know to resize it is with so CSS in userChrome.css.

Does anything change if you start in Safe Mode?


Exit SeaMonkey
(Backup)
Rename localstore.rdf to localstore.rdf.NOT
Start SeaMonkey

Fixed?
If not, exit, restore the name back to original (overwriting the newly created version with the older).


As a test, if you create a new, clean Profile, does the problem repeat itself there?
(Reporter)

Comment 5

6 years ago
Yes, Ctrl+D..... not from inside the Bookmarks Manager.  Haven't tried filing a bookmark from within Manager...  I'll try that when I get a spare minute...

I'll also try some of these experiments when I get a few minutes.... up to my earlobes just now....  SeaMonkey is in continuous use for the foreseeable future.
In reply to comment #4:
Yes, either Ctrl+D or "Bookmarks → File Bookmark", but on SeaMonkey 2.7a1 for Linux64. So if I can resize the dialog and the reporter doesn't, it may mean either that the problem was fixed between Sm2.3 and Sm2.7, or that the problem happens on Windows but not on Linux.

Comment 7

6 years ago
Hmm according to the code you shouldn't be able to resize the window on any platform with "Bookmarks → File Bookmark".
(In reply to Philip Chee from comment #7)
> Hmm according to the code you shouldn't be able to resize the window on any
> platform with "Bookmarks → File Bookmark".

Well, in Sm 2.7a1 on Linux I can: when I hover the mouse over an edge of the dialog the mouse cursor becomes an arrow pointing against a bar, over a corner an arrow inside a right-angle, and dragging it then moves the edge or the corner.

It might be a Gnome function rather than a Mozilla function — that, I wouldn't know; but after closing and reopening the dialog the new width is remembered, even if the close was by [ Cancel ].
(Reporter)

Comment 9

6 years ago
Hi Guys,
I haven't had time to try any serious experimentation but I have looked for the userChrome style sheet and I don't have one.  I have some userChrome examples but they don't have any sizing language in them.  

As I mentioned, I'm up to my earlobes and haven't had an opportunity to shut my machine down and try safe mode...  I am going to try the localstore experiment in a few minutes.  BTW I have two monitors and the bookmark window has now grown so large that it extends about 30% into the second monitor.  In fact it's easier to use since the "save" button and controls are now clearly visible without having to move the window.  Also, I tried adding a bookmark from the Manager path and it comes up just as wide...

Later...
In reply to comment #9:
- userChrome.css doesn't exist by default.
- It lives in the chrome subfolder of your profile folder.
- In some versions there is a userChrome-example.css with a lot of examples, all commented-out.
- For more details, see:
http://kb.mozillazine.org/Profile_folder_-_SeaMonkey
http://kb.mozillazine.org/UserChrome.css
http://kb.mozillazine.org/UserChrome.css_and_userContent.css
http://kb.mozillazine.org/UserChrome-example.css
http://kb.mozillazine.org/Chrome_element_names_and_IDs
http://kb.mozillazine.org/DOM_Inspector
(Reporter)

Comment 11

6 years ago
Got it fixed....  renaming localstore.rdf did the trick....  I found at least 6 or 7 versions of localstore.rdf.  I renamed each one, one at a time until one worked.  My bookmark window is a nice small size and doesn't seem to be growing.

As for userChrome. I did find userChrome-examples.css.  I'll look at the links provided.  

If I ever figure out what caused the expanding dialog I'll post something....

Comment 12

6 years ago
resolving as WFM based on Comment 11 -> cause is bad persisted data in localstore.rdf
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.