Crash while performing any drag and drop operations

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: Petr Motejlek, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.2) Gecko/20100101 Firefox/6.0.2
Build ID: 20110902133214

Steps to reproduce:

Tried to (in the most recent 3, 4, 6 and 7 versions)
  - move a tab
  - create a bookmark by dragging the address from address bar into bookmarks
  - anything else that involves drag and drop


Actual results:

FF crashed without giving out any kind of error. The crash does not occur imediately after a mouse button is pressed, but after moving the mouse. In normal operation that's about the time when the transparent image appears.


Expected results:

FF should not have crashed ;).
(Reporter)

Updated

7 years ago
Severity: normal → major
OS: Windows 7 → Windows XP
Priority: -- → P2
Hardware: x86_64 → x86
Version: 6 Branch → unspecified

Comment 1

7 years ago
Please provide a crash id or stacktrace -> https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report

Your user agent shows 6.0 - does the issue occur with Firefox 7?

Does the crash still occur if you start Firefox in Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode

How about with a new, empty profile? http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-profile
Keywords: crash
Priority: P2 → --
Version: unspecified → 7 Branch
(Reporter)

Comment 2

7 years ago
Just to clearify:

The crash occurs with a new empty profile. I'm using domain logons and on a different PC with the same FF and same profile, the problem does not occur. That's actually the reason why I reinstalled the one particular PC on which the crashes occur and even the reinstall did not work.

The crash still occurs in Safe Mode. I've also tried to manually block some plugins in order to see if a combination of those was causing this.
Priority: -- → P2
Version: 7 Branch → unspecified
(Reporter)

Comment 3

7 years ago
Created attachment 563159 [details]
WinDBG stacktrace
(Reporter)

Comment 4

7 years ago
@Tim: You asked whether the issue occurs with Firefox 7. As I stated in my initial comment - I've encountered it in 3, 4, 6 and 7. It's possible it's also in 5, but I have not tested 5.

Comment 5

7 years ago
Please do not set the priority flag - this is only for use by the developers.
Priority: P2 → --

Comment 6

7 years ago
Please do not set the priority flag - this is only for use by the developers.

"Domain logins" - what technology are you using for this? roaming profiles? redirected folders? other?

Please attach the contents from about:support on the problem PC as a text attachment to this report
(Reporter)

Comment 7

7 years ago
@Tim:

I am sorry about the priority flag, I did not mean to change it.

It's redirected folders actually, but there's no difference between local profile and roaming profile in the matter of this issue. The submitted stacktrace was recorded using a local windows profile.
Priority: -- → P2
(Reporter)

Comment 8

7 years ago
Created attachment 563182 [details]
about:support
(Reporter)

Updated

7 years ago
Priority: P2 → --

Updated

7 years ago
Attachment #563182 - Attachment mime type: application/octet-stream → text/html
Can you go to about:crashes, click on the link for your crash and then paste the URL here?
(Reporter)

Comment 10

7 years ago
@Brian R. Bondy:

When this crash happens there is no error message (no anything ;)) outputted (about:crashes is empty). The Firefox windows just disappears. The only thing I am able to get from it is the stacktrace from WinDbg.

Comment 11

7 years ago
The automatic crash reporter does not appear? Do you have Options->Advanced->General->submit crash reports enabled?

Comment 12

7 years ago
What graphics card is that? Do transparency effects work in other programs on that PC?
(Reporter)

Comment 13

7 years ago
I have just found out, that this crash does not occur on the FF 3.X version line. Might be that there is no transparency effect used in those versions.

@aceman:

Yes, the automatic crash reporter indeed does not appear, even though it is and has been already turned on in the options. I believe it is also the default behavior after a clean install.

It is an NVIDIA GeForce 8600GT graphics card using the current 280.26 drivers. 

Could you please point me to another app that uses the same transparency method as does FF so I can test it? I can for example drag and drop icons on the desktop (they turn transparent as well when you move them) and there the transparency works as expected - the icons are transparent when moving and stop being transparent when they're not moving and nothing crashes :D.

Comment 14

7 years ago
I can only think about Thunderbird as an application that could use the same transparency method as Firefox. You can at least drag & drop tabs in it (but I do not get the transparency effect).
What about dragging images from webpages in Firefox? Does it crash too?
Can you disable HW acceleration in Firefox (tools -> options -> advanced ->general). about:support does not show it as enabled, but let us be sure. It also does not show your Nvidia card. Why is that? I wonder what is that RDPDD graphics driver. Can you tell us anything about it? It seems to be something with demote desktop (RDP). Are you using that?
(Reporter)

Comment 15

7 years ago
@aceman:

That TB suggestion was actually useful - when I for example create a contact in address book and try dragging that contact to another contact group - the same crash happens. It's TB 7.0.

Dragging images in FF has the same effect - crash :(.

The about:support page shows RDesktop because I am actually logged in via remote desktop, because when I have time to get here (bugzilla) I am at home. But I can assure you that the crash still occurs no matter how I'm logged in.

And the HW acceleration is acutally on. But turning it off or back on does not make any kind of noticable difference.

Comment 16

7 years ago
I hope you restarted firefox after turning HW acceleration off. And it crashes even with it off?
(Reporter)

Comment 17

7 years ago
@aceman:

What I did was

- started FF
- turned the HW acc off
- dragged a tab -> ff crashed

- started FF
- turned the HW acc on, then off again (to make sure the change was actually processed)
- quit FF
- started FF
- dragged a tab -> ff crashed

- started FF
- turned the HW acc off, then on again
- quit FF
- started FF
- dragged a tab -> ff crashed

BTW: Thanks a lot for your really quick replies ;) I really appreciate them.

Comment 18

7 years ago
(In reply to Petr Motejlek from comment #17)
> @aceman:
> 
> What I did was
> 
> - started FF
> - turned the HW acc off
> - dragged a tab -> ff crashed
I am not sure FF managed to save the changed setting before you made it crash...

> - started FF
> - turned the HW acc on, then off again (to make sure the change was actually
> processed)
> - quit FF
> - started FF
> - dragged a tab -> ff crashed
> 
> - started FF

I think at this step you should have HW acc off so you could only turn it ON. Is 
the next line wrong?

> - turned the HW acc off, then on again
> - quit FF
> - started FF
> - dragged a tab -> ff crashed

Could you please test it simply: turn HW accel off, close FF normally, start FF, drag a tab?
(Reporter)

Comment 19

7 years ago
(In reply to aceman from comment #18)

Yup, that was a typo. I actually turned it on and then off ;).

I just did a clean install, turned it off, restarted and it still crashes.

Comment 20

7 years ago
Do you have any plugins enabled? Those were not listen on the about:support page, try attaching about:plugins if there are any.
(Reporter)

Comment 21

7 years ago
I do all this under -safe-mode with everything disabled. ;)

Comment 22

7 years ago
Safe mode does not disable plugins.
(Reporter)

Comment 23

7 years ago
Still, there are no plugins. about:plugins does not list any.

Comment 24

7 years ago
Maybe you could start Firefox from the command line and see if there are any messages after the crash. I am not sure if it puts warnings there on Windows as there are on linux.
(Reporter)

Comment 25

7 years ago
I've already done that earlier in order to find something new, but I tried it today again anyway. There's absolutely nothing outputed to std output.

Comment 26

6 years ago
Petr -> Is this still an issue with Firefox 9.0.1? Are there any entries under about:support? Have you upgraded your drivers?
(Reporter)

Comment 27

6 years ago
(In reply to Tim (fmdeveloper) from comment #26)
> Petr -> Is this still an issue with Firefox 9.0.1? Are there any entries
> under about:support? Have you upgraded your drivers?

Hello Tim. Thanks for the heads up. I would have never tried updating if it was not for you ;). Fortunatelly, it seems that this is no longer an issue with the latest FF 10. Thanks a lot to all of you.

Comment 28

6 years ago
(In reply to Petr Motejlek from comment #27)
> it seems that this is no longer an issue
> with the latest FF 10. Thanks a lot to all of you.

Closing as WFM - glad the issue is now resolved for you
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 29

6 years ago
(In reply to Tim (fmdeveloper) from comment #28)
> (In reply to Petr Motejlek from comment #27)
> > it seems that this is no longer an issue
> > with the latest FF 10. Thanks a lot to all of you.
> 
> Closing as WFM - glad the issue is now resolved for you

It seems to me that now FF does some checking before it tries to utilize transparency and therefore does not crash because it now acts the same as FF 3 did - no transparency when drag&dropping :)
You need to log in before you can comment on or make changes to this bug.