Last Comment Bug 690120 - Firefox 7 - Warning on textarea (Warning: Use of getAttributeNode() is deprecated. Use getAttribute() instead.)
: Firefox 7 - Warning on textarea (Warning: Use of getAttributeNode() is deprec...
Status: VERIFIED FIXED
[qa!]
: regression, verified-beta
Product: Core
Classification: Components
Component: Editor (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla10
Assigned To: :Ms2ger
:
Mentors:
: 669400 (view as bug list)
Depends on:
Blocks: 661327
  Show dependency treegraph
 
Reported: 2011-09-28 15:08 PDT by enzo_nanni
Modified: 2012-01-04 08:06 PST (History)
13 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
wontfix
wontfix
verified


Attachments
SampleWarningTextArea.htm (183 bytes, text/html)
2011-09-28 15:08 PDT, enzo_nanni
no flags Details
Patch v1 (1.89 KB, patch)
2011-10-23 04:31 PDT, :Ms2ger
ehsan: review+
Details | Diff | Splinter Review

Description enzo_nanni 2011-09-28 15:08:47 PDT
Created attachment 563191 [details]
SampleWarningTextArea.htm

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0) Gecko/20100101 Firefox/7.0
Build ID: 20110922153450

Steps to reproduce:

I created a textarea


Actual results:

Error Console return:
Warning: Use of getAttributeNode() is deprecated. Use getAttribute() instead.

With Firefox 6 everything was ok.
Comment 1 Bill Gianopoulos [:WG9s] 2011-09-28 15:11:12 PDT
So, you got a warning telling you that what your site was doing was no longer going to be supported, and it pointed you towards what to do to fix it.  Exactly what is your question here?
Comment 2 Alice0775 White 2011-09-28 20:19:54 PDT
I know that the warning message was added by Bug 661327.
However, no getAttributeNode()is  in the attachement html.
So,I think the warning message should not expose in this case.
Comment 3 Jochem Heicke 2011-10-05 07:05:34 PDT
The warning is triggered by entering a value into the textarea.

<textarea autocomplete="off"></textarea>

no warning on page load but when accessing the textarea.

without autocomplete="off" the warning is triggered on every reload

So the problem is INSIDE Firefox and see also

https://developer.mozilla.org/En/DOM/Attr#Deprecated_properties_and_methods

for a NOGO situation soon to come
Comment 4 Masatoshi Kimura [:emk] 2011-10-22 08:21:22 PDT
nsEditor should stop using GetAttributeNode().
https://mxr.mozilla.org/mozilla-central/source/editor/libeditor/base/nsEditor.cpp#1261
Comment 5 :Ms2ger 2011-10-23 04:31:20 PDT
Created attachment 568939 [details] [diff] [review]
Patch v1
Comment 6 :Ehsan Akhgari 2011-10-25 08:48:18 PDT
Comment on attachment 568939 [details] [diff] [review]
Patch v1

Beautiful!
Comment 8 :aceman 2011-11-10 13:17:26 PST
ms2ger, could you please also fix bug 674437 in the same way?
Comment 9 rtrappman 2011-11-12 16:54:59 PST
Looks like: https://bugzilla.mozilla.org/show_bug.cgi?id=669400

Also, you should Reopen this bug: I'm able to reproduce in Firefox 8: 
"Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0) Gecko/20100101 Firefox/8.0 Firefox/8.0"

Warning: Use of getAttributeNode() is deprecated. Use getAttribute() instead.
Source File: chrome://browser/content/scratchpad.xul
Line: 0

AND

Warning: Use of getAttributeNode() is deprecated. Use getAttribute() instead.
Source File: chrome://browser/content/places/places.xul
Line: 0
Comment 10 Masatoshi Kimura [:emk] 2011-11-12 17:02:40 PST
*** Bug 669400 has been marked as a duplicate of this bug. ***
Comment 11 Masatoshi Kimura [:emk] 2011-11-12 17:05:00 PST
(In reply to Rhett Trappman from comment #9)
> Also, you should Reopen this bug: I'm able to reproduce in Firefox 8: 
This fix will not be release until Firefox 10 (see Target Milestone field).
Comment 12 George 2011-11-15 18:26:36 PST
To reproduce the bug:
Click inside an empty text box, to set the keyboard focus.
Like the one that I am writing this comment in. ;)

Start typing: bug reproduced!
Note that getAttributeNode() and getAttribute() may not even be preset in the source of the web page. The bug is still reproduced.

I tried to disable all extensions, but that didn't resolve it.

Versions tested: Firefox 7:reproduced every time and Firefox 8:reproduced every time.

DATE: 2011-November-16, AM 4:26 GMT+2
STATUS: NOT RESOLVED!
Comment 13 Thomas Ahlblom 2011-11-15 18:38:53 PST
(In reply to George from comment #12)
> Versions tested: Firefox 7:reproduced every time and Firefox 8:reproduced
> every time.
> 
> DATE: 2011-November-16, AM 4:26 GMT+2
> STATUS: NOT RESOLVED!

The Target Milestone is Firefox 10 as already stated in comment 11.

Are you able to reproduce it in Firefox 10 or later as well?
Comment 14 j.j. 2011-11-15 19:48:57 PST
Could this land on Aurora and Beta? Would save some bugzilla activity.
Comment 15 :Ms2ger 2011-11-16 00:21:33 PST
Saving some bugzilla activity is no reason to backport patches.

That said, the patch is perfectly safe to backport, but IMO not worthwhile enough to do so.
Comment 16 j.j. 2011-11-16 00:40:10 PST
> Saving some bugzilla activity 
Includes saving time and nerve-shattering of x-thousands of confused web developers who care about console warnings what we always tell them they should but most of them care not because some warnings make no sense for them
Comment 17 George 2011-11-16 17:26:28 PST
Not reproduced on version 10.
On the other hand SGV rendering is completely broken on Aurora 10!
This is a pre-alpha version and is not ready for the public.

Firefox console is a good tool for to checking a web site under development.
Comment 18 Masatoshi Kimura [:emk] 2011-11-16 21:35:20 PST
> On the other hand SGV rendering is completely broken on Aurora 10!
Please file a new bug about that.
Comment 19 :Ehsan Akhgari 2011-12-28 15:32:49 PST
This is not the sort of fix which is suitable for branches.
Comment 20 Mihaela Velimiroviciu (:mihaelav) 2012-01-04 08:06:12 PST
Mozilla/5.0 (Windows NT 6.1; rv:10.0) Gecko/20100101 Firefox/10.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0) Gecko/20100101 Firefox/10.0
Mozilla/5.0 (X11; Linux i686; rv:10.0) Gecko/20100101 Firefox/10.0

Verified the fix using the test page from comment #0 and no message was displayed in the error console at page load nor when typing in the text box.

Note You need to log in before you can comment on or make changes to this bug.