Last Comment Bug 690131 - text-overflow: ellipsis; causes images not to be displayed
: text-overflow: ellipsis; causes images not to be displayed
Status: RESOLVED DUPLICATE of bug 690187
: regression
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 684266
Blocks: 312156
  Show dependency treegraph
 
Reported: 2011-09-28 15:33 PDT by Jan Gerber
Modified: 2011-12-14 17:15 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
image inside of div with text-overflow: ellipsis; get replaced by ellipsis (1.52 KB, text/html)
2011-09-28 15:33 PDT, Jan Gerber
no flags Details

Description Jan Gerber 2011-09-28 15:33:47 PDT
Created attachment 563203 [details]
image inside of div with text-overflow: ellipsis; get replaced by ellipsis

Placing an Image inside of a div that has text-overflow: ellipsis;
The Image is not show.
Test case attached and visible at  http://0x2620.org/html/bugs/Firefox7_elipsis.html

Other browsers show the image instead of ...
Comment 1 Boris Zbarsky [:bz] 2011-09-28 18:41:38 PDT
Jan, that's what the spec says to do.

Tantek, how many of these do we need before the spec changes?  ;)
Comment 2 j.j. 2011-10-14 08:58:57 PDT
Mozilla/5.0 (Windows NT 5.1; rv:10.0a1) Gecko/20111014 Firefox/10.0a1

NOT fixed with bug 684266 (image isn't displayed)
Comment 3 Boris Zbarsky [:bz] 2011-10-14 09:45:52 PDT
That's expected, for now...
Comment 4 Mats Palmgren (:mats) 2011-10-14 10:44:51 PDT
This is the correct rendering per the relevant specs:

http://dev.w3.org/csswg/css3-ui/#text-overflow
"... implementations must hide characters and atomic inline-level elements at the applicable edge(s) of the line as necessary to fit the ellipsis/string"

images are "replaced inline-level elements" and thus "atomic inline-level":

http://www.w3.org/TR/CSS21/visuren.html#inline-boxes
"Inline-level boxes that are not inline boxes (such as replaced inline-level elements, inline-block elements, and inline-table elements) are called atomic inline-level boxes because they participate in their inline formatting context as a single opaque box."
Comment 5 Mats Palmgren (:mats) 2011-10-14 10:47:20 PDT
I don't think the spec will change in this regard, but please reopen if it does.
If you want to raise a spec issue, the www-style mailing list is right forum.
Comment 6 Boris Zbarsky [:bz] 2011-10-14 11:11:21 PDT
> I don't think the spec will change in this regard,

That sort of depends on how web-incompatible this behavior is.... from what I can see so far, it's pretty web-incompatible.
Comment 7 Tantek Çelik 2011-10-14 18:01:22 PDT
Boris, how do we decide "how web-incompatible" anything in particular is?

For this particular issue/bug, let's start tracking real world URLs - since that's what should determine "web-incompatible" or not.

I've created a wiki page/section for this: https://wiki.mozilla.org/CSS/text-overflow#issues

Thanks.
Comment 8 Boris Zbarsky [:bz] 2011-10-14 18:50:03 PDT
> For this particular issue/bug, let's start tracking real world URLs

Yep.  See the bugs blocking bug 312156 and their duplicates, if any.
Comment 9 j.j. 2011-11-17 20:02:57 PST
*** Bug 703360 has been marked as a duplicate of this bug. ***
Comment 10 j.j. 2011-12-14 17:15:40 PST
The specification changed an this might be fixed soon.

*** This bug has been marked as a duplicate of bug 690187 ***

Note You need to log in before you can comment on or make changes to this bug.