Crash on win2000 if using new Function('e','...') in addEventListener

VERIFIED DUPLICATE of bug 31847

Status

()

--
critical
VERIFIED DUPLICATE of bug 31847
18 years ago
17 years ago

People

(Reporter: mozilla_kan_blokkes, Assigned: joki)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; 0.7) Gecko/20010109
BuildID:    2001010901

Mozilla 0.7 will crash on win2000 (not right away but after 5 seconds of 
mouseactivity) if you try to use a dynamic function as EventListener, the 
following code will make it crash:

document.addEventListener('mousemove',new 
Function('e','window.status="("+e.pageX+","+e.pageY+")"'),true);

You can see the bug here: http://mbj.dk/mozilla7crash.html

Reproducible: Always
Steps to Reproduce:
1. Go to http://mbj.dk/mozilla7crash.html
2. move your mouse around
3. Enjoy windows-popup: generating error log...

Actual Results:  Well... mozilla crashed....

Expected Results:  not crash...

nothing to report here really, standard machine setup PIII 600 Mhz 128 MB ram, 
mozilla doesn't have any problems on it except for that one.
I can't a current linux build from cvs to crash after several minutes of mouse
activity... is this windows-only or fixed since 0.7?  Reporter, could you try  a
more recent build?
(Reporter)

Comment 2

18 years ago
To clear up confusion: it is a win2000 problem only afaik

Comment 3

18 years ago
Confirming on 2001021304 on Win2k. It takes me quite a lot of mousing around.
Then Mozilla just plain quits. DrWatson doesn't get a chance to create a stack
trace.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

18 years ago
Dupe of existing bug

*** This bug has been marked as a duplicate of 31847 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
QA contact updated
QA Contact: gerardok → madhur

Comment 6

17 years ago
verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.