Skip IMAP folders on import from Outlook

RESOLVED FIXED in Thunderbird 11.0

Status

MailNews Core
Import
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Mike Kaganski, Assigned: Mike Kaganski)

Tracking

({perf})

unspecified
Thunderbird 11.0
All
Windows 7
Bug Flags:
in-litmus ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

6 years ago
When importing mail from MS Outlook, we should skip folders that represent IMAP accounts, as their contents will be accessible in TB.
(Assignee)

Comment 1

6 years ago
Created attachment 563277 [details] [diff] [review]
Skip IMAP folders on import from Outlook

David, please test how it works. Unfortunately, I cannot test it at the moment.
Attachment #563277 - Flags: review?(dbienvenu)
(Assignee)

Comment 2

6 years ago
See also Bug 592022 - there a user suffered from being unable to import an IMAP folder from OE.
Probably, there should be some way for user to decide if he wants to import IMAP mails or not...
(Assignee)

Comment 3

6 years ago
Created attachment 563710 [details] [diff] [review]
Alternative patch

This patch does the same as attachment 563277 [details] [diff] [review], with the following differences:
1. It creates empty folders for each folder in the origial IMAP account (previous one creates only the root folder for the account);
2. It reports the skipped IMAP folders in the Import Results window.

The test describing the reason to skip is hardcoded in this patch; if this patch will be chosen as the way to go then this text should be made into strings bundle (I have no idea how to do this).

Possible further improvements:
1.a Don't create those empty folders, or
1.b Put a faik email in those folders tellind the reason why this folder was skipped
2. Let user decide if (s)he wants to skip IMAP or not (this would require making some UI, that's beyond my skills).
Attachment #563710 - Flags: review?(dbienvenu)
this could be a nice perf win for import of large accounts
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: in-litmus?
Keywords: perf

Comment 5

6 years ago
Comment on attachment 563277 [details] [diff] [review]
Skip IMAP folders on import from Outlook

I ran with this, and it did skip the imap folders, but it created an empty folder with the name of the imap account - I'd prefer that it didn't do that, if possible. Other than that, I think it's OK to silently skip imap accounts. If we were actually creating the imap accounts and populating the imap offline store with the contents of the Outlook offline store, then I could see doing so (though I don't that would work technically because the version on the imap server is what we want).
Attachment #563277 - Flags: review?(dbienvenu) → review+

Comment 6

6 years ago
Comment on attachment 563710 [details] [diff] [review]
Alternative patch

minusing based on comments (don't want empty files)
Attachment #563710 - Flags: review?(dbienvenu) → review-

Comment 7

6 years ago
Mike, are you ok with my landing the first patch?
(Assignee)

Comment 8

6 years ago
David, of course, I'm OK with this.
However, I'd prefer at least to tell the user the reason why a mailbox was skipped...

Comment 9

6 years ago
(In reply to Mike Kaganski from comment #8)
> David, of course, I'm OK with this.
> However, I'd prefer at least to tell the user the reason why a mailbox was
> skipped...

I think the better solution here would be to setup the imap account in Thunderbird, if there was an IMAP account in Outlook, and the corresponding account wasn't in Thunderbird.

Updated

6 years ago
Keywords: checkin-needed
Checked in: http://hg.mozilla.org/comm-central/rev/1052fda15cbc
Assignee: nobody → mikekaganski
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 11.0
You need to log in before you can comment on or make changes to this bug.