Add test to verify that video controls work when viewing a standalone video

RESOLVED WONTFIX

Status

()

Toolkit
Video/Audio Controls
RESOLVED WONTFIX
7 years ago
5 months ago

People

(Reporter: jaws, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Comment hidden (empty)
Created attachment 563278 [details] [diff] [review]
Patch for bug 690208
Attachment #563278 - Flags: review?(dolske)
Created attachment 563621 [details] [diff] [review]
Patch for bug 690208

Fixed some typos in the comments.
Attachment #563278 - Attachment is obsolete: true
Attachment #563278 - Flags: review?(dolske)
Attachment #563621 - Flags: review?(dolske)
Comment on attachment 563621 [details] [diff] [review]
Patch for bug 690208

Test?! r+!

Suggest you do tryserver run, though, specifically on Android. Mobile uses a slightly different set of controls, so I'm dubious about this test passing there.
Attachment #563621 - Flags: review?(dolske) → review+
https://hg.mozilla.org/mozilla-central/rev/d9ff4a720e19
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla10
https://hg.mozilla.org/mozilla-central/rev/e9152e5f0708
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla10 → ---
This test should add an listener for |document-element-inserted| to reproduce the conditions that caused the standalone video controls to fail in bug 689106.

Components.classes["@mozilla.org/observer-service;1"]  
          .getService(Components.interfaces.nsIObserverService)
          .addObserver({ observe: function () {} }, "document-element-inserted", false);
The patch that was landed for Bug 678465 checks to make sure that VideoDocuments that observe |document-element-inserted| continue to function.
Assignee: jAwS → nobody
Obsolete due to comment #8.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago5 years ago
Resolution: --- → WONTFIX
For posterity, the test that was attempted to land here later landed in https://hg.mozilla.org/mozilla-central/rev/baaf5eafdf51
You need to log in before you can comment on or make changes to this bug.