TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_bug638292.js | Test timed out | Found a tab after previous test timed out

RESOLVED WORKSFORME

Status

()

Toolkit
Add-ons Manager
RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: mbrubeck, Assigned: mounir)

Tracking

(Blocks: 1 bug, {intermittent-failure})

10 Branch
x86
Windows 7
intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
This happened on two of the last three Win opt builds on mozilla-inbound.  If it continues to be anywhere near that frequent, it must have been caused by a pretty recent push.

https://tbpl.mozilla.org/php/getParsedLog.php?id=6601453&tree=Mozilla-Inbound
Rev3 WINNT 6.1 mozilla-inbound opt test mochitest-other on 2011-09-28 18:29:06 PDT for push 0c9d0f4f1c82

and

https://tbpl.mozilla.org/php/getParsedLog.php?id=6602181&tree=Mozilla-Inbound
Rev3 WINNT 6.1 mozilla-inbound opt test mochitest-other on 2011-09-28 19:16:48 PDT for push 6032f7c15af8

INFO TEST-END | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_bug611242.js | finished in 338ms
TEST-INFO | checking window state
TEST-INFO | unknown test url | before wait for focus -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/browser.xul focused window: ([object Window]) about:blank desired window: ([object ChromeWindow]) chrome://browser/content/browser.xul child window: ([object Window]) about:blank docshell visible: true
TEST-INFO | unknown test url | already focused
TEST-INFO | unknown test url | maybe run tests <load:true, focus:true> -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/browser.xul focused window: ([object Window]) about:blank desired window: ([object ChromeWindow]) chrome://browser/content/browser.xul child window: ([object Window]) about:blank docshell visible: true
TEST-START | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_bug638292.js
TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_bug638292.js | Console message: [JavaScript Error: "redeclaration of var Cc" {file: "chrome://browser/content/content.js" line: 3}]
TEST-INFO | unknown test url | before wait for focus -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/browser.xul focused window: ([object Window]) http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/bug638292.html desired window: ([object Window]) http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/bug638292.html child window: ([object Window]) http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/bug638292.html docshell visible: true
TEST-INFO | unknown test url | already focused
TEST-INFO | unknown test url | maybe run tests <load:true, focus:true> -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/browser.xul focused window: ([object Window]) http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/bug638292.html desired window: ([object Window]) http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/bug638292.html child window: ([object Window]) http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/bug638292.html docshell visible: true
TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_bug638292.js | Clicking link 1
TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_bug638292.js | Console message: [JavaScript Error: "redeclaration of var Cc" {file: "chrome://browser/content/content.js" line: 3}]
TEST-PASS | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_bug638292.js | installTrigger should have been enabled
TEST-INFO | unknown test url | before wait for focus -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/browser.xul focused window: ([object Window]) http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/bug638292.html desired window: ([object Window]) http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/bug638292.html child window: ([object Window]) http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/bug638292.html docshell visible: true
TEST-INFO | unknown test url | already focused
TEST-INFO | unknown test url | maybe run tests <load:true, focus:true> -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/browser.xul focused window: ([object Window]) http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/bug638292.html desired window: ([object Window]) http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/bug638292.html child window: ([object Window]) http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/bug638292.html docshell visible: true
TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_bug638292.js | Clicking link 2
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_bug638292.js | Test timed out
INFO TEST-END | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_bug638292.js | finished in 30020ms
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_bug638292.js | Found a tab after previous test timed out: http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/bug638292.html
TEST-INFO | checking window state
TEST-INFO | unknown test url | before wait for focus -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/browser.xul focused window: ([object Window]) about:blank desired window: ([object ChromeWindow]) chrome://browser/content/browser.xul child window: ([object Window]) about:blank docshell visible: true
TEST-INFO | unknown test url | already focused
TEST-INFO | unknown test url | maybe run tests <load:true, focus:true> -- loaded: complete active window: ([object ChromeWindow]) chrome://browser/content/browser.xul focused window: ([object Window]) about:blank desired window: ([object ChromeWindow]) chrome://browser/content/browser.xul child window: ([object Window]) about:blank docshell visible: true
TEST-START | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_bug645699.js
TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_bug645699.js | Console message: [JavaScript Error: "redeclaration of var Cc" {file: "chrome://browser/content/content.js" line: 3}]
(Reporter)

Comment 1

7 years ago
Another two, both on Windows XP:

https://tbpl.mozilla.org/php/getParsedLog.php?id=6602312&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound opt test mochitest-other on 2011-09-28 19:36:19 PDT for push 6032f7c15af8

https://tbpl.mozilla.org/php/getParsedLog.php?id=6601789&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound opt test mochitest-other on 2011-09-28 19:05:09 PDT for push ec855ff26e8d

That makes it four out of the last six opt runs on Win+WinXP.  Unfortunately, a lot of the builds right before that did not get Windows test runs, so it's not as easy as it could be to narrow this down.
Comment hidden (Treeherder Robot)

Comment 3

7 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=6603339&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound opt test mochitest-other on 2011-09-28 21:13:59 PDT
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
And comment 9 moves it back before https://hg.mozilla.org/integration/mozilla-inbound/rev/ec855ff26e8d, which was going to be my candidate.
(Reporter)

Comment 11

7 years ago
Created attachment 563443 [details] [diff] [review]
back out bug 675574

Philor retriggered test runs on these builds:
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=2780356be1a1 https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=455bee36af33

which provided evidence that this was probably caused by 2780356be1a1 (bug 675574).  Attaching a backout patch since I went to the trouble of updating it to apply across the s/PRBool/bool/ change.  Mounir wants to try a quick fix, so I'll wait before landing this backout.
(Reporter)

Updated

7 years ago
Blocks: 675574
(Assignee)

Comment 12

7 years ago
Created attachment 563445 [details] [diff] [review]
Patch

This should fix this test but I will open a follow-up because I don't think this test needs to have this pref disabled and I don't see why the anti-multiple popup code happens to be called here...
Assignee: nobody → mounir
Status: NEW → ASSIGNED
Attachment #563445 - Flags: review?(mbrubeck)
(Reporter)

Comment 13

7 years ago
Comment on attachment 563445 [details] [diff] [review]
Patch

Worth a try.
Attachment #563445 - Flags: review?(mbrubeck) → review+
(Assignee)

Updated

7 years ago
Whiteboard: [orange] → [inbound]
Whiteboard: [inbound] → [inbound][orange]
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 27

7 years ago
Sorry, I backed this out along with the patch from bug 675574 because even after the patch from bug 690220 we are also still seeing an increase in M-oth shutdown timeouts that we think are likely to be caused by this patch.  After this fix landed on inbound, the shutdown timeouts happened on all platforms.  (Before that they were seen on Windows only.)

https://hg.mozilla.org/integration/mozilla-inbound/rev/3bb95f690d75

We'll see if this backout fixes the shutdown timeouts.  And before re-landing these patches, let's push them to Try and retrigger M-oth on all platforms several times.
Comment hidden (Treeherder Robot)

Comment 29

7 years ago
https://hg.mozilla.org/mozilla-central/rev/9928fb9a32b1

The backout will be merged later...
Target Milestone: --- → mozilla10
Comment hidden (Treeherder Robot)
(Reporter)

Comment 31

7 years ago
The fix is backed out on mozilla-central, along with bug 675574 which caused this bug.  See comment 27 above for discussion of the backout and future testing and re-landing.
https://hg.mozilla.org/mozilla-central/rev/3bb95f690d75
Whiteboard: [inbound][orange] → [orange]
Target Milestone: mozilla10 → ---
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Keywords: intermittent-failure
Whiteboard: [orange]
Resolving WFM any keyword:intermittent-failure bug where:
* Changed: (is less than or equal to) -3m
* Whiteboard: (contains none of the strings) random disabled marked fuzzy todo fails failing annotated time-bomb
* Whiteboard: (does not contain the string) leave open

There will inevitably be some false positives; for that (and the bugspam) I apologise, but at least this will clear out the open cruft (and thus reduce risk of mis-starring) on TBPL's annotated summary bug suggestions.

Filter on orangewfm.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.