web console should give clear result when possible

RESOLVED DUPLICATE of bug 682033

Status

()

Firefox
Developer Tools
RESOLVED DUPLICATE of bug 682033
6 years ago
6 years ago

People

(Reporter: dindog, Unassigned)

Tracking

7 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:7.0) Gecko/20100101 Firefox/7.0
Build ID: 20110928030855

Steps to reproduce:

Firefox's build-in web developer tools are much useless compare to Chrome. We could do better.
Some simple results:
document.scripts
document.images

we got object HTMLCollection.
document.scripts[0]
document.images[0]
we got object HTMLImageElement & object HTMLScriptElement. When click on it, show a lot detail.

Chrome's console gave thing like:
<img src="" alt=""> or <script type="text/javascripts" src=""></script>

simple yet useful info. It should work better, in fact, firefox pick up so many "Chrome style" since Fx4, Chrome build-in developer tools is definitly we should learn from.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 682033
You need to log in before you can comment on or make changes to this bug.