Last Comment Bug 690370 - Fx app update deletes customized pref defaults (defaults\pref\all.js)
: Fx app update deletes customized pref defaults (defaults\pref\all.js)
Status: VERIFIED WONTFIX
:
Product: Toolkit
Classification: Components
Component: Application Update (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Robert Strong [:rstrong] (use needinfo to contact me)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-29 08:43 PDT by al_9x
Modified: 2011-09-29 15:06 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description al_9x 2011-09-29 08:43:48 PDT
1. unpack a non current nightly zip
2. add a defaults\pref\all.js
3. perform a help->about update
4. all.js gets deleted
Comment 1 Kevin Brosnan [:kbrosnan] 2011-09-29 08:51:16 PDT
custom prefs can be placed in /path/to/firefox/defaults/profile/user.js
Comment 2 al_9x 2011-09-29 08:58:16 PDT
These are not custom prefs, but custom defaults.  Why are they deleted?  An installer update does not delete them.
Comment 3 Robert Strong [:rstrong] (use needinfo to contact me) 2011-09-29 10:40:58 PDT
Installing on top of with the installer should delete them which I'll verify when I have a chance.

Custom preferences should be in a file that is not one of the Firefox prefs files under defaults\pref\.

The reason it is deleted is because this Firefox prefs file has been moved into the omni.jar file. Also, the old file contains values that have been changed and some of the changes will cause breakage.

Leaving open to verify that the installer does delete all.js, etc.
Comment 4 al_9x 2011-09-29 11:22:12 PDT
(In reply to Robert Strong [:rstrong] (do not email) from comment #3)
> Custom preferences should be in a file that is not one of the Firefox prefs
> files under defaults\pref\.

all.js does not appear to be a firefox installed file, it is neither in defaults\pref\ nor in omni.jar, so why again are you deleting a user supplied defaults file?
Comment 5 Robert Strong [:rstrong] (use needinfo to contact me) 2011-09-29 12:34:30 PDT
Sorry about accidentally resolving it fixed.

Just had a chance to look into this and all.js was removed during an update as far back as Firefox 1.5
http://mxr.mozilla.org/mozilla1.8.0/source/browser/installer/removed-files.in#10

To prevent this from happening you will need to use a pref file name that has never been used by Firefox. A safe bet would be to prefix the file name with an _.

We aren't going to change Firefox so this file isn't deleted so wontfixing.
Comment 6 al_9x 2011-09-29 13:10:06 PDT
(In reply to Robert Strong [:rstrong] (do not email) from comment #5)
> We aren't going to change Firefox so this file isn't deleted so wontfixing.

Deleting a user supplied defaults file is incorrect behavior, not saying this is a high priority, but WONTFIX is inappropriate, confirm it and leave it open.
Comment 7 Robert Strong [:rstrong] (use needinfo to contact me) 2011-09-29 15:05:21 PDT
No, it isn't considered a user supplied defaults pref file because the all.js pref file used to exist in Firefox. This is why it is deleted it on update. Any pref file name that has ever existed is not considered supported. We are not going to change that policy and we aren't going to fix this bug so please don't reopen.

Note You need to log in before you can comment on or make changes to this bug.