TI: "Assertion failure: sn && ((JSSrcNoteType)(((*(sn) >> 3) >= SRC_XDELTA) ? SRC_XDELTA : *(sn) >> 3)) == SRC_SWITCH,"

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: gkw, Unassigned)

Tracking

(Blocks: 2 bugs, {assertion, testcase})

Trunk
x86
Mac OS X
assertion, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: js-triage-needed)

Attachments

(2 attachments)

Created attachment 563427 [details]
testcase

The attached testcase asserts 64-bit js debug shell on JM changeset 55f463c562d4 with -m, -a, -d and -n at Assertion failure: sn && ((JSSrcNoteType)(((*(sn) >> 3) >= SRC_XDELTA) ? SRC_XDELTA : *(sn) >> 3)) == SRC_SWITCH, which should be passed in to the shell as a CLI argument.
Also occurs on 64-bit Mac m-c rev dbb129f069b1, but does not seem to occur in 32-bit.
(In reply to Gary Kwong [:gkw, :nth10sd] from comment #2)
> Also occurs on 64-bit Mac m-c rev dbb129f069b1, but does not seem to occur
> in 32-bit.

I take that back, it seems to only reproduce on JM but not on m-c, had tested the wrong shell previously.
Is the comment 0 cset correct?  It dates back from March, and doesn't repro the assertion.
(In reply to Brian Hackett from comment #4)
> Is the comment 0 cset correct?  It dates back from March, and doesn't repro
> the assertion.

No, I must have pasted the wrong one. Please test with 44ef245b8706 (from bug 690376 or bug 690292)
I'm unable to reproduce this assert on m-c now.

-> WFM
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.