Invited users should have email confirmation pre-filled to 1

VERIFIED INVALID

Status

Participation Infrastructure
Phonebook
P3
minor
VERIFIED INVALID
6 years ago
5 years ago

People

(Reporter: ozten, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
If a user is invited and they register the same email address as the invite was sent too, then they should not have to confirm their email address. The confirm field in their profile should be created with 1 instead of 0.

Steps to Reproduce:
1) Login with vouched user A
2) Invite user B at b@example.com
3) Logout
4) Click invitation link and register user B

Leave b@example.com in the Primary email field

5) Complete account creation and log out
6) Login as user B

Expected:
User is logged in and can use search, etc

Actual:
You need to confirm your account before you can log in. Resend confirmation email?
(Reporter)

Updated

6 years ago
Severity: normal → minor
Agreed with the bug and the severity. Would this be worthwhile as a "[goodfirstbug]", Austin ?
(Reporter)

Comment 2

6 years ago
Account code can be tricky for first bugs, but I'll defer to davedash who wrote this feature. mentor=davedash... would be the keyword he would add if appropriate.
If you implement this, then the invitation mails shouldn't be sent with the inviter's mail address as sender, else bouncing mails provide the opportunity for him to register with that other address.

Updated

6 years ago
Priority: -- → P3
Whiteboard: [mentor=dd@mozilla.com]

Updated

6 years ago
Component: mozillians.org → Phonebook
Product: Websites → Community Tools
QA Contact: mozillians-org → phonebook
Version: unspecified → other
Agree with the reasoning behind this bug request. It would be good for someone to pick up as a first bug with help from a mentor.

Dave, do you still want to be a mentor on this bug?
Whiteboard: [mentor=dd@mozilla.com] → [mentor=dd@mozilla.com][ux]

Comment 5

5 years ago
Hi, I would like to try and fix this bug. I am a beginner can you please guide me through it ?
Whiteboard: [mentor=dd@mozilla.com][ux] → [mentor=glogiotatidis@mozilla.com][ux]
yashness, thanks for offering to fix this bug! Giorgos can help yo with this bug. You can chat with him in the #commtools IRC channel or ask some questions here to get started.

Here is a good place to learn how to get Mozillians running on your local machine:
http://mozillians.readthedocs.org/en/latest/installation-virtualenv.html
Assignee: nobody → yash9414
Thanks for your interested yashness. Unfortunately this bug does not apply anymore since we're using Persona, thus the email is already verified.

We'll talk on IRC to find you another bug to start with.

Thanks!
Assignee: yash9414 → nobody
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
Whiteboard: [mentor=glogiotatidis@mozilla.com][ux]
yashness, thanks again. We'll see you on irc. There are plenty of boogs that you can get involved on. QA verified invalid.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.