[traceback] SMTPRecipientsRefused: {'': (501, '5.1.3 Bad recipient address syntax')} when doing password reset on staging

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
7 years ago
6 years ago

People

(Reporter: stephend, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 563501 [details]
Screenshot

Traceback (most recent call last):

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/core/handlers/base.py", line 111, in get_response
    response = callback(request, *callback_args, **callback_kwargs)

  File "/data/www/mozillians.allizom.org/mozillians/apps/users/views.py", line 111, in password_reset
    reverse('password_reset_check_mail'))

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/utils/decorators.py", line 91, in _wrapped_view
    response = view_func(request, *args, **kwargs)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/contrib/auth/views.py", line 160, in password_reset
    form.save(**opts)

  File "/data/www/mozillians.allizom.org/mozillians/apps/users/forms.py", line 185, in save
    send_mail(subject, email, from_email, [user.email])

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/core/mail/__init__.py", line 61, in send_mail
    connection=connection).send()

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/core/mail/message.py", line 248, in send
    return self.get_connection(fail_silently).send_messages([self])

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/core/mail/backends/smtp.py", line 86, in send_messages
    sent = self._send(message)

  File "/data/www/mozillians.allizom.org/mozillians/vendor/src/django/django/core/mail/backends/smtp.py", line 104, in _send
    email_message.message().as_string())

  File "/usr/lib/python2.6/smtplib.py", line 709, in sendmail
    raise SMTPRecipientsRefused(senderrs)

SMTPRecipientsRefused: {'': (501, '5.1.3 Bad recipient address syntax')}

Updated

7 years ago
Component: affiliates.mozilla.org → mozillians.org
QA Contact: affiliates-mozilla-org → mozillians-org

Comment 1

7 years ago
Is this reproducible with a new account?

When was this account registered?

This Traceback was a known issue in code which was on production before the official launch. Any of those old accounts will exhibit this behavior.
(Reporter)

Comment 2

7 years ago
No, I can't reproduce this -- marking WFM.  Thanks!
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME

Updated

7 years ago
Component: mozillians.org → Phonebook
Product: Websites → Community Tools
QA Contact: mozillians-org → phonebook
Version: unspecified → other

Updated

6 years ago
Severity: blocker → normal
Status: RESOLVED → VERIFIED
Thanks stephend - bumping to verified worksforme
You need to log in before you can comment on or make changes to this bug.