mozillians.org failed to create my account, took me to login screen without reporting error

VERIFIED FIXED

Status

Participation Infrastructure
Phonebook
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: Jono Xia, Unassigned)

Tracking

Details

(Reporter)

Description

7 years ago
I just followed the link in the invitation email I received today (http://www.mozillians.org), created an account, and then tried to log in using the email and password that I had just created.  I get sent to the incorrect password screen.

The password I picked is pretty long, but I trust we're not doing anything silly in the code that would make that a problem, right?
(Reporter)

Comment 1

7 years ago
Using the "reset password" link tells me that there is no account for the email address I entered (jono@mozilla.com).  So it seems the real bug is that the account was not created.
(Reporter)

Comment 2

7 years ago
OK, I went through the account creation page again.  This time it worked (after I corrected a mismatch between the two password fields).  Now I seem to be logged in.

I guess the first time, my account was not created, but instead of showing me an error, it took me to the login screen.  Seems to be a bug with error handling.
(Reporter)

Updated

7 years ago
Summary: Can't log in to mozillians.org using the password I just created → mozillians.org failed to create my account, took me to login screen without reporting error
Thanks for the find, Jono. One question: did you confirm the account via e-mail in between registering the account and logging in with it?
(Reporter)

Comment 4

7 years ago
Nope, I didn't even see the confirmation email until later.  The sequence was like:

1. create account on account creation page
2. get taken to login page (with email and password prefilled)
3. try to log in several times, fail
4. file bug
5. try to recover password, get told there is no account for my email
6. go back to account creation page, try again to make account
7. this time log in successfully
8. notice that I got a confirmation mail in my inbox
After following up with Jono, he mentioned this only happened the first time he tried to log-in. We should look into the flow of profile registration here. Tobbi, Raymond, can you try reproducing this issue?
Tobbi: ping ?
(In reply to Aakash Desai [:aakashd] from comment #6)
> Tobbi: ping ?

I will try to reproduce it later this day.

Updated

6 years ago
Component: mozillians.org → Phonebook
Product: Websites → Community Tools
QA Contact: mozillians-org → phonebook
Version: unspecified → other
With BrowserID and a better infra set in place for the Phonebook, we haven't seen these issues.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 9

6 years ago
Triage, please verify if no longer an issue.

Comment 10

6 years ago
Resolving, I was able to register new accounts with issue. This was likely resolved when persona was implemented.

If we get more reports we can re-open.
Status: RESOLVED → VERIFIED

Comment 11

6 years ago
Correction on above

Resolving, I was able to register new accounts without issue.
You need to log in before you can comment on or make changes to this bug.