Compose window address list won't resize smaller once made bigger

RESOLVED FIXED in Thunderbird 10.0

Status

Thunderbird
Message Compose Window
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Joe Drew (not getting mail), Assigned: squib)

Tracking

unspecified
Thunderbird 10.0

Thunderbird Tracking Flags

(thunderbird8+ fixed, thunderbird9+ fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Put several addresses into your compose window. Resize the address list:

http://imgur.com/92faF

Now try to resize it smaller:

http://imgur.com/c6lsc

This seems to be a permanent state for the compose window now.
That's an interesting one. Using DOM Inspector, I can find the toolbox element with id="FormatToolbar" and change its height to something small to reset the location of the bar.
tracking-thunderbird8: --- → ?
Err, I meant id="FormatToolbox"
(Assignee)

Comment 3

6 years ago
Created attachment 563580 [details] [diff] [review]
Fix this

So the issue here is that, previously, the next sibling of the splitter had flex="1" so everything worked out. Then the splitter got moved above the FormatToolbox, which wasn't flexy. The solution is to make the flexy vbox encompass both the FormatToolbox and the message body.

Here's a patch to do this, which is mostly indentation changes.
Assignee: nobody → squibblyflabbetydoo
Status: NEW → ASSIGNED
Attachment #563580 - Flags: review?(mbanner)
Summary: address list won't resize smaller once made bigger → Compose window address list won't resize smaller once made bigger
tracking-thunderbird8: ? → +
tracking-thunderbird9: --- → +
Duplicate of this bug: 691311
Comment on attachment 563580 [details] [diff] [review]
Fix this

r=me. Please also use hg transplant to put this on aurora & beta. I don't think this will adversely affect extensions, and I'd like to push the fix out as soon as possible.
Attachment #563580 - Flags: review?(mbanner)
Attachment #563580 - Flags: review+
Attachment #563580 - Flags: approval-comm-beta+
Attachment #563580 - Flags: approval-comm-aurora+
(Assignee)

Comment 6

6 years ago
Checked in:

http://hg.mozilla.org/comm-central/rev/4ab5a3448398
http://hg.mozilla.org/releases/comm-aurora/rev/4cd6e224028d
http://hg.mozilla.org/releases/comm-beta/rev/f3abe099d38e
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
status-thunderbird8: --- → fixed
status-thunderbird9: --- → fixed
OS: Mac OS X → All
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 10.0
(Assignee)

Updated

6 years ago
Duplicate of this bug: 698032
(Assignee)

Updated

6 years ago
Duplicate of this bug: 695632
You need to log in before you can comment on or make changes to this bug.