Allow search by IRC nickname

VERIFIED FIXED

Status

Participation Infrastructure
Phonebook
P1
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: Unfocused, Assigned: ozten)

Tracking

Details

(Whiteboard: [1.0.1])

Sometimes, the only identifying name you have for someone is their IRC nickname. So, it'd be useful to be able to search on that.
Fixed; That came in with 1.0 :)
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Kidding! This seems to be broken. We're saying that folks can search by IRC nick, but those nicks aren't getting registered.
Status: RESOLVED → REOPENED
Priority: -- → P1
Resolution: FIXED → ---
Target Milestone: --- → 1.1
(Assignee)

Comment 3

6 years ago
Andrew Findlay and tofumatt here is a pull request for code review.

https://github.com/mozilla/mozillians/pull/21
Assignee: nobody → ozten.bugs
(Assignee)

Updated

6 years ago
Whiteboard: [1.0.1]

Comment 4

6 years ago
Commit pushed to https://github.com/mozilla/mozillians

https://github.com/mozilla/mozillians/commit/708e04680c1e5fd886370881c68bf119d8fdb87f
Search under people against irc nick, load if found. First stab at fixing Bug#690551
(Assignee)

Comment 5

6 years ago
We now make a second search and load people by IRC nick. Both searches are combined and unique results shown. A simple sort by full name was added, which will be refined in a later bug such as Bug#690423.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Duplicate of this bug: 691866
Verified searching by IRC nickname works on stage.
Status: RESOLVED → VERIFIED

Comment 8

6 years ago
Commit pushed to https://github.com/mozilla/mozillians

https://github.com/mozilla/mozillians/commit/708e04680c1e5fd886370881c68bf119d8fdb87f
Search under people against irc nick, load if found. First stab at fixing Bug#690551

Updated

6 years ago
Component: mozillians.org → Phonebook
Product: Websites → Community Tools
QA Contact: mozillians-org → phonebook
Target Milestone: 1.1 → ---
Version: unspecified → other
You need to log in before you can comment on or make changes to this bug.