Translations with only a rejected revision show as green on Most Visited Translations dashboard

RESOLVED FIXED in 2012.7

Status

P2
normal
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: erik, Assigned: willkg)

Tracking

unspecified
2012.7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=contributor c=wiki p=2)

(Reporter)

Description

7 years ago
A translation with only a single revision, which is rejected, shows as up-to-date on the Most Visited Translations l10n dashboard. It should show as Needing Translation.
(Reporter)

Comment 1

7 years ago
Here's a failing test for it:

    def test_one_rejected_revision(self):
        """A translation with only 1 revision, which is rejected, should show
        as "Needs Translation"."""
        translation = translated_revision(is_approved=False,
                                          reviewed=datetime.now(),
                                          save=True)
        row = self.row()
        eq_('untranslated', row['status_class'])

Comment 2

7 years ago
Dupe of bug 688960?
(Reporter)

Comment 3

7 years ago
I don't think so; that bug complains about the URL locale prefix being "cs" while the page content is predominantly English. It never mentions the l10n dashboard.

Comment 4

7 years ago
(In reply to Erik Rose [:erik][:erikrose] from comment #3)
> I don't think so; that bug complains about the URL locale prefix being "cs"
> while the page content is predominantly English. It never mentions the l10n
> dashboard.
https://support.mozilla.com/cs/kb/zasuvny-modul-adobe-flash-spadl/history has only a single revision, which is rejected and shows as up-to-date in the Czech dashboard: https://support.mozilla.com/cs/localization instead of Needing Translation.
Scoobi, I commented in that thread. The yellow bar says that the article is not localized yet, since the only translation was rejected. That's how it's supposed to work.

In this case though the article is marked as up-to-date in the localization dashboard.
Cleaning up 2011Q4
Target Milestone: 2011Q4 → ---

Updated

7 years ago
Priority: -- → P2
Whiteboard: u=contributor c=wiki s=2012.5 p=
Assignee: erik → nobody
OS: Mac OS X → All
Hardware: x86 → All
Judging from the work on Bug 645546, making this a 2pter.
Whiteboard: u=contributor c=wiki s=2012.5 p= → u=contributor c=wiki s=2012.5 p=2
Pruning 2012.5 bug list.
Whiteboard: u=contributor c=wiki s=2012.5 p=2 → u=contributor c=wiki s=2012.6 p=2
Sprint based milestone :-)
Target Milestone: --- → 2012.6
Whiteboard: u=contributor c=wiki s=2012.6 p=2 → u=contributor c=wiki p=2

Updated

7 years ago
Target Milestone: 2012.6 → 2012.7
Grabbing this one.

First, I'll verify that it's still an issue and see if the test still works. If it is, then I'll work on fixing it.
Assignee: nobody → willkg
I verified that this test still fails. I'm looking into it now.
Landed in master in https://github.com/mozilla/kitsune/commit/5db3db4a6d8c53596a3ebece49c9bf77801f7548

Pushed to stage this morning. Tested with this one: https://support.allizom.org/ak/localization/most-visited-translations

It's got a single Akan translation that was reviewed and rejected. The document shows up in the Most Visited Translations section as "translation needed".

Pushed to production just now.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.