Last Comment Bug 690655 - I cannot re-edit vCard using the previous values
: I cannot re-edit vCard using the previous values
Status: RESOLVED FIXED
: regression, testcase
Product: Thunderbird
Classification: Client Software
Component: Address Book (show other bugs)
: 7 Branch
: x86 Windows Vista
: -- major with 4 votes (vote)
: Thunderbird 11.0
Assigned To: Mike Conley (:mconley) - (Away until June 29th)
:
Mentors:
Depends on:
Blocks: 664726 761852
  Show dependency treegraph
 
Reported: 2011-09-29 21:52 PDT by Kaz Nishimura
Modified: 2012-07-15 19:50 PDT (History)
14 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed
fixed


Attachments
screenshot of broken vCard edit dialog (43.54 KB, image/png)
2011-10-05 01:33 PDT, Daniel
no flags Details
not working vcard from prefs.js (457 bytes, text/plain)
2011-10-05 10:05 PDT, Michal Kozusznik
no flags Details
2nd not working vcard from prefs.js (438 bytes, application/octet-stream)
2011-10-05 13:00 PDT, Daniel
no flags Details
vcard (258 bytes, text/plain)
2011-10-05 13:31 PDT, Daniel
no flags Details
Patch v1 (594 bytes, patch)
2011-11-15 12:20 PST, Mike Conley (:mconley) - (Away until June 29th)
mozilla: review+
standard8: approval‑comm‑aurora+
Details | Diff | Review
Screenshot of my error console 05/01/2012 (244.06 KB, image/jpeg)
2012-01-06 06:55 PST, keithknight@kpkmail.co.uk
no flags Details

Description Kaz Nishimura 2011-09-29 21:52:26 PDT
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:7.0) Gecko/20100101 Firefox/7.0
Build ID: 20110922153450

Steps to reproduce:

(I uses the Japanese-localized version of Thunderbird so UI terms may be incorrect.)

1) I checked to attach vCard in an account and edit my vCard.
2) I mailed to my self to see if my vCard looks good.
3) I opened the account setting and attempted to edit my vCard again.


Actual results:

First time edited vCard was sent with my test message, but when I tried to edit my vCard again, the editor dialog is all blank.  It seems that the program cannot retrieve the previous values from my vCard.


Expected results:

When I try to edit my vCard, the editor should be filled with the previously entered values.
Comment 1 Michal Kozusznik 2011-10-03 14:18:03 PDT
I can confirm it.
Issue noticed in TB7.0.1. It is possibly that issue appeared in some previous versions. But during the last 30 days, for sure

Two different vCards are set for 2 different accounts. vCards are sent with every email. but I'm not able to edit those: all fields are empty.

Issue appears on 2 different computers. In both cases: Windows 7 64bit, Czech language, Thunderbird with Czech language.

best regards
Comment 2 Ludovic Hirlimann [:Usul] 2011-10-04 01:24:25 PDT
Any errors in Tools -> Error console when you try to edit the Card ?
Comment 3 Michal Kozusznik 2011-10-04 02:14:53 PDT
(In reply to Ludovic Hirlimann [:Usul] from comment #2)
> Any errors in Tools -> Error console when you try to edit the Card ?

None.
Comment 4 Michal Kozusznik 2011-10-04 04:24:58 PDT
(In reply to Ludovic Hirlimann [:Usul] from comment #2)
> Any errors in Tools -> Error console when you try to edit the Card ?

None.
Comment 5 Ludovic Hirlimann [:Usul] 2011-10-04 04:52:56 PDT
I'm not seeing this with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:9.0a2) Gecko/20111003 Thunderbird/9.0a2. 

Does it happens all the time ?
Do you have extension installed ?
Comment 6 Michal Kozusznik 2011-10-04 05:01:55 PDT
I have installed following plugins:
- Czech dictionaties
- Google COntacts 0.6.37
- Lightning 1.0b7
- Provider for Google Calendar 0.8
- SmtpSwitch 1.0.3 (issue appeared before this plugin has been installed)
- Sync Kolab 1.5.2

After disabling all plugins the issue persists.

It is possible I had some national characters in vCard (maybe it is a reason). I may include this vCard here if you point me how to find that.

best regards
Comment 7 Daniel 2011-10-05 01:30:38 PDT
Same here with Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20110929 Thunderbird/7.0.1 ID:20110929044556

Plugins I use:
- Lightning 1.0b7
- Provider for Google Calendar 0.8
- German dictionaries

It doesn't matter if I try to edit a previously saved vCard of an account or an vCard of alias identitys. In both cases all fields stays emtpy. The dialogs showing up does more look like an create-dialog instead of edit-dialog.

The vCard gets sent out, just edit wont work. I try to post screenshot of the edit dialog.
Comment 8 Daniel 2011-10-05 01:33:51 PDT
Created attachment 564766 [details]
screenshot of broken vCard edit dialog

This dialog opens when I try to edit an previously saved vCard, its a german one.
Comment 9 Ludovic Hirlimann [:Usul] 2011-10-05 04:36:35 PDT
(In reply to Daniel from comment #7)

So no themes ?
 
> The vCard gets sent out, just edit wont work. I try to post screenshot of
> the edit dialog.

Save the vcard. come back to this webpage and use the add an attachment link above to attach the vcard here.

Ludo
Comment 10 Michal Kozusznik 2011-10-05 10:05:49 PDT
Created attachment 564908 [details]
not working vcard from prefs.js
Comment 11 Daniel 2011-10-05 13:00:00 PDT
Created attachment 564969 [details]
2nd not working vcard from prefs.js

I just filled in test data in every field, and attached the file.

Forgot to mention that I use the theme Silvermel and Charamel XT V. 1.4.3, but doesn't matter if its enabled or disabled, makes no difference.
Comment 12 Daniel 2011-10-05 13:31:13 PDT
Created attachment 564984 [details]
vcard

as requested a vcard, the 2nd prefs.js attachment is using same data.

I filled in "Test" in the field nickname (german: Spitzname) of the edit-dialog in the account-setup, but it seems to miss in the vcard which gets attached to the mail.

In the attached screenshot you can see I have no tabs labeled "private", "picture" or "other" in the account-vcard-creation dialog like this vcard-add-dialog has when I click the vcard itself in the mail, I don't know if this normal. Maybe someone with a working dialog can attach a screenshot?
And I removed the theme I had before, no change.
Comment 13 Mike Conley (:mconley) - (Away until June 29th) 2011-10-06 08:50:25 PDT
Reproduced on Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0a2) Gecko/20111003 Thunderbird/9.0a2

I'll look into it.
Comment 14 Alexander Bergmann 2011-10-27 01:15:57 PDT
I am not sure, if this a new bug or it is related to this bug:

However, after you have created your vCard using "Edit vCard" in the "Account Settings" - editing it again doesn't show the vCard as reported in this bug report(!) - the vCard is not shown in the "Address Book" either.

If I then switch from "Personal Address Book" to "Collected Addresses", I get the following error message in the error console of Thunderbird:

Error: An error occurred updating the cmd_delete command: [Exception... "'[JavaScript Error: "cards[i] is null" {file: "chrome://messenger/content/addressbook/abResultsPane.js" line: 158}]' when calling method: [nsIController::isCommandEnabled]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://global/content/globalOverlay.js :: goUpdateCommand :: line 80"  data: yes]
Source File: chrome://global/content/globalOverlay.js
Line: 86

Arch Linux / Thunderbird 7.0.1
Comment 15 klonos 2011-10-29 03:30:46 PDT
Win 7 x64 with latest Thunderbird (Daily) 10.x:

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111028 Thunderbird/10.0a1

This happens in all contacts in my address book. I cannot edit/save them anymore. Pressing the "OK" button does nothing (I think that this button used to say "Save" before ???). Here's what I see in Tools -> Error console.

Warning: Use of getAttributeNode() is deprecated. Use getAttribute() instead.
Source File: chrome://messenger/content/addressbook/abEditCardDialog.xul
Line: 0

Tested in a fresh profile (no themes/addons) as well with only my abook.mab, abook-*.mab & history.mab transferred from my old profile.

It's been quite some time since I last needed to edit or add a contact in my address book, so I can't tell when this started happening.
Comment 16 1manfactory 2011-11-08 02:29:17 PST
I have the same problems.
Can't edit/modify already created vcards from my account settings.
Thunderbird 7.01
No error messages in Tools/Error, only messages and warnings
Comment 17 Michal Kozusznik 2011-11-08 15:30:43 PST
Today, after more than a month the bug is still not fixed. But it is not a problem to release Thunderbird 8. You are lame.
Comment 18 Ivan Voras 2011-11-14 04:12:57 PST
Same here, Thunderbird on FreeBSD.
Comment 19 Mike Conley (:mconley) - (Away until June 29th) 2011-11-14 06:15:02 PST
Hey all,

Another project has taken priority over this one, but I promise I will be coming back to fix this bug as soon as possible.  Please be patient.

All the best,

-Mike
Comment 20 Mike Conley (:mconley) - (Away until June 29th) 2011-11-15 12:20:26 PST
Created attachment 574649 [details] [diff] [review]
Patch v1

This is a regression caused by bug 664726 - some element ID's got changed, and it looks like this file wasn't updated.
Comment 21 Daniel 2011-11-15 13:25:33 PST
After applying your patch to the file omni.jar\chrome\messenger\content\messenger\addressbook\abCardOverlay.js line 4 it seems to work now, I can edit the v-card now.

Thanks for your work.
Comment 22 Mike Conley (:mconley) - (Away until June 29th) 2011-11-15 13:32:44 PST
Committed to comm-central as http://hg.mozilla.org/comm-central/rev/99d3461b9489

I've requested approval for aurora and beta - we'll see how it goes.
Comment 23 Mike Conley (:mconley) - (Away until June 29th) 2011-11-15 14:29:43 PST
Comment on attachment 574649 [details] [diff] [review]
Patch v1

Ugh, sorry Christian.  I selected the wrong Aurora / Beta flags.  :/  That's like the third time this week.  Gonna need to tattoo this one on my forehead.
Comment 24 1manfactory 2011-11-16 04:19:08 PST
I don't get this.
Is this now fixed or not?
I don't understand what you are talking about.
There is no "abCardOverlay.js" on my system (WinXP).
What fix was that for? Apparently not for the vcard edit problem.
Comment 25 Mark Banner (:standard8) 2011-11-16 04:25:41 PST
(In reply to 1manfactory from comment #24)
> Is this now fixed or not?

This is currently fixed in the Thunderbird 11 builds, it will be ported to TB 10 & 9 very soon.

> There is no "abCardOverlay.js" on my system (WinXP).

It is contained within one of the files that gets installed. I don't recommend trying to modify it unless you know what you are doing.

> What fix was that for? Apparently not for the vcard edit problem.

Please don't be negative. If it wasn't for the vcard edit problem specified in this bug then this bug wouldn't now be marked as fixed, as the patch wouldn't have been able to get review and land.
Comment 26 Mike Conley (:mconley) - (Away until June 29th) 2011-11-16 06:55:40 PST
Committed to comm-aurora as http://hg.mozilla.org/releases/comm-aurora/rev/22f47b166a2e
Committed to comm-beta as http://hg.mozilla.org/releases/comm-beta/rev/94ae04ebdf9a

All:  Thanks for your patience with this one, and sorry for the regression.  This fix should hit Thunderbird 9 beta in the next build.
Comment 27 1manfactory 2011-11-16 07:48:41 PST
(In reply to Mark Banner (:standard8) from comment #25)
> (In reply to 1manfactory from comment #24)
> > Is this now fixed or not?
> 
> This is currently fixed in the Thunderbird 11 builds, it will be ported to
> TB 10 & 9 very soon.
> 
> > There is no "abCardOverlay.js" on my system (WinXP).
> 
> It is contained within one of the files that gets installed. I don't
> recommend trying to modify it unless you know what you are doing.
> 
> > What fix was that for? Apparently not for the vcard edit problem.
> 
> Please don't be negative. If it wasn't for the vcard edit problem specified
> in this bug then this bug wouldn't now be marked as fixed, as the patch
> wouldn't have been able to get review and land.

Guys,
This bug report is about
Platform: x86 Windows Vista
Topic: "I cannot re-edit vCard using the previous values"
And this "fix" does not fix THIS specific problem. Hence, from my point of view, it is misplaced here.
But please correct me if I am wrong.
Editing vcards may not be essential to a lot of you. But for me it is a vital point. And as far as I see there has no clear and prober statement been made here regarding
1) how to fix and
2) when this will be fixed
Instead of pushing out new RC versions every 4 weeks with new features no one has asked for I would really love somebody to concentrate on bug fixing.
Thunderbird used to be a very good software because one could rely on fast bug fixes. I am missing that.
Maybe I will skip TB8 and go directly to TB9, that is ridiculous.
Comment 28 Mike Conley (:mconley) - (Away until June 29th) 2011-11-16 07:57:02 PST
Hey 1manfactory,

> And this "fix" does not fix THIS specific problem.
> ...
> But please correct me if I am wrong.

I assure you, my patch does fix this particular problem of being unable to edit your identity vCard.

> 2) when this will be fixed

The fix for this has landed in repositories for TB 9, 10 and 11.  When a new build of TB 9 beta is completed, it will have this fix.

> Instead of pushing out new RC versions every 4 weeks...
> I would really love somebody to concentrate on bug fixing.

Every 6 weeks, not 4.  And I can assure you that we are fixing bugs for each release - and getting them out to users faster than we would have in the past.

All the best,

-Mike
Comment 29 David :Bienvenu 2011-11-16 07:58:57 PST
When we check a fix for a problem into our source code respository, we mark the bug fixed. That does not mean the fix has been released/shipped but it does mean that the next version that is shipped/released will have the fix.
Comment 30 keithknight@kpkmail.co.uk 2012-01-06 06:05:06 PST
Just to say this error appears in my error console for version 9.0.1 and is not therefore released or if it is, requires further work.
When will the fix be released/fixed please ???
thank you
Keith Knight
Comment 31 Mike Conley (:mconley) - (Away until June 29th) 2012-01-06 06:34:09 PST
Keith:

Hm, so I cannot seem to reproduce the issue using a clean install of Thunderbird 9.0.1 on Windows 7.

Can you please go to Help > Troubleshooting Information, and paste your User Agent string into this bug?

If you could do the same with the Error Console message, that'd be excellent.

Thank you,

-Mike
Comment 32 keithknight@kpkmail.co.uk 2012-01-06 06:45:22 PST
UAS - as requested by Mike Conley
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0) Gecko/20111222 Thunderbird/9.0.1
Keith Knight
Comment 33 keithknight@kpkmail.co.uk 2012-01-06 06:52:58 PST
This error appeared in my error console and when pasted into Bugzilla search led me to this bug. I am trying to process the errors in  my error console. I have a completely clean install.
I am new to this. I have a jpg image of my error console. Please advise how I can include this.
Keith Knight
Comment 34 keithknight@kpkmail.co.uk 2012-01-06 06:55:59 PST
Created attachment 586412 [details]
Screenshot of my error console 05/01/2012

Sorry Mike. I have attached the required screenshot. I believe the error in question that I pasted into Bugzillla is this one:
Warning: Use of getAttributeNodeNS() is deprecated. Use getAttributeNS() instead.
Source File: chrome://messenger/content/messenger.xul
Line: 0
I fail to see how this produces this bug but that is where I was led.
Comment 35 Mike Conley (:mconley) - (Away until June 29th) 2012-01-06 07:00:46 PST
Keith:

Hm, alright.  Can you try disabling all of your add-ons, and seeing if the problem still persists?

-Mike
Comment 36 keithknight@kpkmail.co.uk 2012-01-06 07:13:15 PST
After disabling addons, the following addressbook error persists:
Warning: Use of getAttributeNode() is deprecated. Use getAttribute() instead.
Source File: chrome://messenger/content/addressbook/abEditCardDialog.xul
Line: 0
Keith
Comment 37 Mike Conley (:mconley) - (Away until June 29th) 2012-01-06 07:56:57 PST
Keith:

The error persists, but are you able to edit and re-edit your personal vCard?  If so, then we should open a separate bug for the getAttributeNode deprecation warning.

-Mike
Comment 38 keithknight@kpkmail.co.uk 2012-01-06 08:07:07 PST
I can still edit all my addressbooks. As stated I have no functional issues - just a persistent error console message which, when entered into Bugzilla search leads me to this bug!!
If you look at the file in the Omni.jar repository, the string getAttributeNodeNS, doesn't even exist, so I have no idea how to proceed. I presume is an error processing fault. I would just like to get rid of it in my error console. It has no priority for me. Most of the errors in my error console are CSS syntax or JS calling errors that have little or no impact on function but the console is there for us to resolve or log bugs, so that is what I am doing. Sorry.
Keith Knight
Comment 39 Thomas Sisson 2012-07-15 19:50:41 PDT
I can't save changes to address book contacts now. It now says OK instead of Save. Change it back to Save because OK is confusing and the code is coincidentally not working.

I know this is an experimental unsupported build, but someone needs to get 64 bit working for the anticipated Windows 8 release in October. I'm using Windows 7, not 8 prerelease.

User agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:16.0) Gecko/16.0 Firefox/16.0 SeaMonkey/2.13a1
    Build identifier: 20120715165713

Note You need to log in before you can comment on or make changes to this bug.