Crash @nsXBLProtoImplField::InstallField after upgrade from 7.0 to 7.0.1.

RESOLVED DUPLICATE of bug 688637

Status

()

P1
critical
RESOLVED DUPLICATE of bug 688637
7 years ago
7 years ago

People

(Reporter: John.Kitz, Unassigned)

Tracking

7 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

After closing all open tabs, accepted auto upgrade from 7.0 to 7.0.1. The same happened during the auto upgrade from the last release of the 6.0.x branch to 7.0, suggesting a bug was introduced around the time of the release of 7.0. However, I did not report the crash at the time.


Actual results:

FF crashed and showed crash reporter window. In addition McAfee asked to grant FF access to the Internet twice.


Expected results:

FF should have been upgrade to the latest release and restarted upon completion.
(Reporter)

Updated

7 years ago
Severity: normal → critical
Priority: -- → P1
(Reporter)

Comment 1

7 years ago
Details of the crash in crash report: bp-f7328413-5903-41ac-a6ad-32c672110930
(Reporter)

Updated

7 years ago
Crash Signature: bp-f7328413-5903-41ac-a6ad-32c672110930
Did it crash when you tried to launch after the first crash?
Also, did you see any UI prior to the crash?
The update appears to be successful based on the dll and exe versions in the crash.

Since the crash occurred in XBL changing the component. This might be due to an interaction with McAfee.
Component: Installer → XBL
Product: Firefox → Core
QA Contact: installer → xbl
Summary: FF crashed during auto upgrade from 7.0 to 7.0.1. → Crash @nsXBLProtoImplField::InstallField after upgrade from 7.0 to 7.0.1.
Found a duplicate
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 688637
(Reporter)

Comment 6

7 years ago
(In reply to Robert Strong [:rstrong] (do not email) from comment #2)
> Did it crash when you tried to launch after the first crash?

No, it crashed during the upgrade process, prior to showing the upgrade progress bar in the middle of the screen.

(In reply to Robert Strong [:rstrong] (do not email) from comment #3)
> Also, did you see any UI prior to the crash?

Not from FF, see above. McAfee did prompt me twice though.

(In reply to Robert Strong [:rstrong] (do not email) from comment #4)
> The update appears to be successful based on the dll and exe versions in the
> crash.
> 
> Since the crash occurred in XBL changing the component. This might be due to
> an interaction with McAfee.

FF started OK after the crash and "help -> about" shows the correct version information indicating that the upgrade did complete successfully despite the crash.
You need to log in before you can comment on or make changes to this bug.