Fennecomb landscape mode tab bar works badly with more than 3 tabs on Galaxy Tab 10.1

RESOLVED DUPLICATE of bug 687510

Status

Fennec Graveyard
General
RESOLVED DUPLICATE of bug 687510
6 years ago
6 years ago

People

(Reporter: hsivonen, Unassigned)

Tracking

(Depends on: 1 bug)

Trunk
ARM
Android
Dependency tree / graph

Details

(Reporter)

Description

6 years ago
Steps to reproduce:
 1) Run Nightly on Galaxy Tab 10.1
 2) Turn the tablet into the landscape mode.
 3) Open 6 tabs.
 4) Close one tab.
 5) Look at the tab bar.

Actual results:
The tab bar shows 4 open tabs and one closed tab. You can't tell if you have only 4 tabs open or if there are more tabs open (in this case, there's a fifth tab!).

Expected results:
Expected the tab switcher to be able to visualize more tabs. When the limit of how many tabs can be shown is reached, expected there to be some indicator than more tabs are available if you scroll the list.

Additional info:
This problem could be solved by using the same tab switcher that's used in the portrait mode also in the landscape mode.
The tab switcher in portrait mode has it's own set of problems, see bug 688836.

Updated

6 years ago
Depends on: 688836
This will be better when we add a fade to the bottom of the tab sidebar (bug 687510). I'm tempted to just resolve this a dup of that bug.
Depends on: 687510
Agreed and done
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 687510
You need to log in before you can comment on or make changes to this bug.