Closed Bug 690760 Opened 11 years ago Closed 3 years ago

Closing the Fennecomb landscape mode tab bar often makes it look like you accidentally closed a tab

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: hsivonen, Unassigned)

References

Details

(Keywords: ux-userfeedback)

Steps to reproduce:
 1) Run Nightly on Honeycomb.
 2) Turn the tablet into the landscape orientation.
 3) Open so many tabs that the tab bar is full of them.
 4) Swipe the tab bar closed.

Actual results:
When there's no free space in the tab bar, you have to start the swipe at a vertical position that's occupied by a tab. If your finger lands near the middle of the right edge of a tab, the close X on the tab highlight as you swipe. The tab isn't closed, but the highlight makes it look like you hit the close X, so you end up reopening the tab bar to check if you accidentally closed the tab and reclosing it.

Expected results:
Expected the UI not to make me think I closed a tab accidentally.
Happens in portrait view too.
(In reply to Martijn Wargers [:mw22] (QA - IRC nick: mw22) from comment #1)
> Happens in portrait view too.

Can't happen, because there's no tab bar to close!
Summary: Closing the Fennecomb landscape mode tab often makes it look like you accidentally closed a tab → Closing the Fennecomb landscape mode tab bar often makes it look like you accidentally closed a tab
You can't close the tab bar in landscape mode, you mean. You can close the tab bar popup, though.
Depends on: 688836
(In reply to Martijn Wargers [:mw22] (QA - IRC nick: mw22) from comment #3)
> You can't close the tab bar in landscape mode, you mean. You can close the
> tab bar popup, though.

Right, but this is a problem that happens when swiping to close the sidebar, which doesn't apply to the portrait tab menu.

We should cancel the tap highlight while dragging the sidebar.
Blocks: 655762, 686417
Keywords: ux-userfeedback
Closing all opened bug in a graveyard component
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.