Last Comment Bug 690834 - replace PR_TRUE and PR_FALSE in plugin code outside of dom/plugins
: replace PR_TRUE and PR_FALSE in plugin code outside of dom/plugins
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: mozilla10
Assigned To: Josh Aas
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-30 10:56 PDT by Josh Aas
Modified: 2011-10-03 07:55 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix v1.0 (43.33 KB, patch)
2011-09-30 10:56 PDT, Josh Aas
roc: review+
Details | Diff | Splinter Review

Description Josh Aas 2011-09-30 10:56:38 PDT
Created attachment 563778 [details] [diff] [review]
fix v1.0
Comment 1 Josh Aas 2011-10-01 08:45:06 PDT
pushed to mozilla-inbound

http://hg.mozilla.org/integration/mozilla-inbound/rev/31bad59be74f
Comment 2 Marco Bonardo [::mak] 2011-10-03 07:55:03 PDT
https://hg.mozilla.org/mozilla-central/rev/31bad59be74f

notice that, due to merge conflicts, some of the changes to nsObjectLoadingContent.cpp may have been lost (I had to do a manual merge :( ). Btw, till the PRBool -> bool regression is figured, we shouldn't convert PR_TRUE/PR_FALSE (see the topic in mozilla.dev.planning) at all, there is still possibility the PRBool to bool will have to be backed out. Also because doing partial conversions across components causes a bunch of merge headaches across trees.

Note You need to log in before you can comment on or make changes to this bug.