Windows 7 Taskbar Previews broken on Nightly

RESOLVED FIXED in mozilla10

Status

()

Core
Widget: Win32
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: WildcatRay, Assigned: sid0)

Tracking

({regression})

Trunk
mozilla10
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [inbound])

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created attachment 563786 [details]
Image of Taskbar Preview Issue

Tab content fails to display in taskbar previews

STR:
1. In new profile, check option to display previews in Taskbar.
2. Hover mouse over taskbar to display of all tabs open in browser.

Expected:
Preview of content of each tab will be shown.

Actual:
See Image attached.
(Reporter)

Updated

6 years ago
Keywords: regression
(Reporter)

Comment 1

6 years ago
Regression range based on Nightly nightly buids:

Changeset cb4b93331e4f: OK

Changeset b5b082d183d0: Not OK
It's similar for me, but my tab previews are the various tabs' favicons.
In addition it also affects if you have other Firefox windows open. Only if the option is enabled.
Created attachment 563793 [details]
Case with one showing favicon (which was in an individual window) and the missed thumbnail-
(Assignee)

Comment 5

6 years ago
Yes, I can reproduce. Looking into it.
(Assignee)

Comment 6

6 years ago
I backed out bug 515907 and the problem still persists, plus that bug doesn't really touch the part of the code that generates previews, so I really doubt it's that.
(Assignee)

Updated

6 years ago
Summary: Bug 515907 Breaks Win7 Taskbar Previews on Nightly → Windows 7 Taskbar Previews broken on Nightly
(Assignee)

Updated

6 years ago
Component: General → Widget: Win32
Product: Firefox → Core
QA Contact: general → win32
(Assignee)

Comment 7

6 years ago
mwu, could your PRBool to bool change have caused this? See <https://hg.mozilla.org/mozilla-central/diff/e7854b4d29ba/widget/src/windows/TaskbarTabPreview.cpp>.
(Assignee)

Comment 8

6 years ago
Yep, I'm pretty sure that's the reason.
Depends on: 675553
No longer depends on: 515907
(Assignee)

Comment 9

6 years ago
Created attachment 563827 [details] [diff] [review]
patch v1

Yep, fallout. We didn't catch this because we were assuming (and not type checking) that PRBool = BOOL.
Assignee: nobody → sagarwal
Status: NEW → ASSIGNED
Attachment #563827 - Flags: review?(mwu)

Updated

6 years ago
Attachment #563827 - Flags: review?(mwu) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/746002692d93
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla10
Ugh, sorry, I always slip up with marking inbound patches as fixed.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: [inbound]
Target Milestone: mozilla10 → ---
(Assignee)

Updated

6 years ago
Blocks: 675553
No longer depends on: 675553
https://hg.mozilla.org/mozilla-central/rev/746002692d93
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla10
(Reporter)

Comment 13

6 years ago
I just grabbed the Nightly hourly (C-set ID 164fd1bbd06f) containing the needed patch and can confirm that Win7 Taskbar Previews have been fixed.

Thanks for the fix. Sorry for the initial misdirection. Just think of it as a little test. ;-)
No worries: my patch was the obvious one to blame.
You need to log in before you can comment on or make changes to this bug.