Closed Bug 690860 Opened 8 years ago Closed 8 years ago

android debug nightly builds

Categories

(Release Engineering :: General, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: blassey, Assigned: lsblakk)

References

Details

Attachments

(6 files)

Since we don't keep tinderbox on-change builds for more than a couple hours, it would be useful for regression hunting to have nightly debug builds
[16:46]	<blassey>	we've had several cases lately where they would have been very helpful
checked with blassey in irc and mozilla-central only is fine. also removing 'enable_mobile_nightly' config because it's not longer used.
Assignee: nobody → lsblakk
Status: NEW → ASSIGNED
Attachment #565584 - Flags: review?(aki)
only adds a mozilla-central nightly linux-android-debug builder to each build master
Comment on attachment 565584 [details] [diff] [review]
buildbot-configs patch (removing some unused lines too)

Thanks Lukas!
Attachment #565584 - Flags: review?(aki) → review+
Attachment #565586 - Flags: review?(aki) → review+
Comment on attachment 565586 [details] [diff] [review]
buildbotcustom changes to enable debug nightlies

http://hg.mozilla.org/build/buildbotcustom/rev/22a7d96f3ea4 on default
Attachment #565586 - Flags: checked-in+
Comment on attachment 565584 [details] [diff] [review]
buildbot-configs patch (removing some unused lines too)

http://hg.mozilla.org/build/buildbot-configs/rev/15672980915d on default
Attachment #565584 - Flags: checked-in+
(In reply to Brad Lassey [:blassey] from comment #0)
> Since we don't keep tinderbox on-change builds for more than a couple hours,
> it would be useful for regression hunting to have nightly debug builds

This struck me as wrong so I checked: 

In short, we *should* have been keeping those Android tinderbox-builds for one month like we do for everything else, but the crontab was also purging builds with "linux" in the name. Since we changed the builder name for Android to include linux a while ago, Android tinderbox-builds were also being expired every hour.

I've fixed this in the crontab, so regression hunting on Android debug builds should be a little easier now.
In that case, I'm going to resolve this - if it turns out that you start to regularly need builds that are older than a month please re-open and we can turn this on.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
[09:55]	<aki>	lsblakk: per the mobile meeting, they'd a) like android debug tinderbox builds longer than 30 days for the time being if we don't have debug nightlies, and
[09:55]	<aki>	b) debug nightlies would be nice still
[09:55]	<aki>	want to land those patches and be done with it?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
http://hg.mozilla.org/build/buildbot-configs/rev/46d7be1f8d9b
http://hg.mozilla.org/build/buildbotcustom/rev/b131210f4aea

re-landed on default branches, will be picked up in the next reconfig.
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
The landed patches are broken.  We are creating the builder name for the scheduler but never creating or adding the actual builder.  Sadly, because we only test multi master codepaths, and the test that checks for non-existant builders doesn't run in multi master mode, this wasn't caught.  I have filed bug 695888 to start testing with universal masters.

When I run checkconfig on code with these patches on a multi-master, I have no errors.  When I run checkconfig on code with these patches on a universal master, I get:

AssertionError: <buildbotcustom.scheduler.SpecificNightly-props instance at 0x105175200> uses unknown builder Android Debug mozilla-central nightly

And, I have verified that the builder isn't in the http status display so I am guessing that it isn't on the master at all.

(testing)~/mozilla/testing $ curl -Li http://buildbot-master08.build.sjc1.mozilla.com:8001/builders/Android%20Debug%20mozilla-central%20nightly
HTTP/1.1 404 Not Found
Date: Wed, 19 Oct 2011 22:49:33 GMT
Content-Length: 153
Content-Type: text/html
Server: TwistedWeb/10.1.0


<html>
  <head><title>404 - No Such Resource</title></head>
  <body>
    <h1>No Such Resource</h1>
    <p>No such child resource.</p>
  </body>
</html>
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
i had a dyslexic moment there
Depends on: 695888
No longer depends on: 659888
Any reason not to back this out?  We don't have nightly android debug builds and its breaking me from using staging bug 692812 properly
Attached patch backout breakageSplinter Review
Attachment #568462 - Flags: review?(lsblakk)
Attachment #568462 - Flags: checked-in?
now we have builders to go with the schedulers
Comment on attachment 569805 [details] [diff] [review]
part 2 of allowing per-platform config to add debug nightlies

[15:12]	<aki>	lsblakk: i think your do_nightly might be extraneous, but it doesn't hurt?
[15:12]	<aki>	since it's not hitting the continue, it'll fall through: https://bugzilla.mozilla.org/attachment.cgi?id=569805&action=edit
[15:13]	<lsblakk>	should i just if not pf.has_key('enable_nightly'): continue ?
[15:13]	<aki>	yeah
Attachment #569805 - Flags: review?(aki) → review+
Comment on attachment 569805 [details] [diff] [review]
part 2 of allowing per-platform config to add debug nightlies

http://hg.mozilla.org/build/buildbotcustom/rev/a2375f100f4f with comments addressed, on default
Attachment #569805 - Flags: checked-in+
Attachment #568462 - Flags: review?(lsblakk)
Attachment #568462 - Flags: checked-in?
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
verified that we have builds now for mozilla-central android debug nightlies in http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.