location bar shows deleted entry not highlighted one

RESOLVED DUPLICATE of bug 669129

Status

()

RESOLVED DUPLICATE of bug 669129
7 years ago
7 years ago

People

(Reporter: reader_1000, Unassigned)

Tracking

6 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.2) Gecko/20100101 Firefox/6.0.2
Build ID: 20110902133214

Steps to reproduce:

I delete an url from history by using delete key in the location bar when urls listed.


Actual results:

Although in the list, next item is highlighted, in the location bar, deleted items url appears. Therefore when you delete an url via delete key from the location bar list and want to load the next url listed by hitting enter (return) key, firefox opens the deleted url because location bar shows the deleted url not the highlighted one.


Expected results:

Location bar should have updated itself to show highlighted entry which appears right after the deleted url and loads the next url when hitted enter (return) key.

Let me write the scenario:
Assume that you write "bugzilla" to the location bar.
Then urls from history comes in this order:
1. https://bugzilla.mozilla.org/enter_bug.cgi#h=bugForm|Firefox
2. https://bugzilla.mozilla.org/
you select the first one (https://bugzilla.mozilla.org/enter_bug.cgi#h=bugForm|Firefox) with down arrow key.
you delete it with delete key.
now in the list second url is highlighted (https://bugzilla.mozilla.org/)
however in the location bar there is still first deleted url (https://bugzilla.mozilla.org/enter_bug.cgi#h=bugForm|Firefox)
you hit enter (return) key to load second url (https://bugzilla.mozilla.org/) since it is highlighted you think that firefox will load it, however it loads the url deleted previously (https://bugzilla.mozilla.org/enter_bug.cgi#h=bugForm|Firefox)

I hope I am clear. Thanks

Updated

7 years ago
Whiteboard: dupeme

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 669129

Updated

7 years ago
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.