Closed Bug 691077 Opened 11 years ago Closed 11 years ago

WebGL in Firefox 4 and higher needlessly triggers discrete GPU in Macbook Pros

Categories

(Core :: Canvas: WebGL, defect)

7 Branch
x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 646043

People

(Reporter: bbirnbaum89, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.23) Gecko/20110920 Firefox/3.6.23
Build ID: 20110920075126

Steps to reproduce:

Opened up Firefox 4 (and higher) to my homepage, www.google.com -- Also browsed several websites and used Firefox with several combos of tabs/windows using Flash, non-flash, video, and non-video content.


Actual results:

My MacBook Pro's NVIDIA GeForce GT 330M ("discrete", "dGPU") GPU was activated. I use the 3rd-party widget called "gfxCardStatus v2.1" to monitor Mac OSX's GPU dynamic switching technology so I can best utilize my battery when browsing the internet. In other words, it tells me when my laptop is using integrated (low power) graphics and discrete (high power) dedicated GPU processing. 

The dGPU was triggered as soon as Firefox 4 (and higher versions) was executed. This issue occurred regardless of the website I was opening to as my homepage. Even text-based websites triggered the discrete GPU. 


Expected results:

In Firefox 3.x (without WebGL), the dGPU would only activate in an "as needed" fashion, such as when viewing a YouTube video in HD/full screen, or when viewing other video content that is best delivered when utilizing a dedicated GPU. This feature was excellent, because the integrated graphics is perfectly sufficient for handling most web content, and even low definition video/flash content. The integrated graphics are also much more economical with battery usage and generates far less heat than a discrete GPU. 

When the discrete GPU activates, not only does power consumption increase, but heat generation does as well. Increased heat requires the fans to increase in RPM, furthering the power consumption. 

It is believed (through research I've done) that it is the WebGL technology in Firefox 4 and higher that tricks Mac OSX into a "permanent state" of dGPU usage (via it's dynamic GPU switching APIs) when browsing the internet and causes a detrimental and irresponsible use of system resources. Browsing the internet in Firefox 4+ on battery power is incredibly and needlessly power inefficient. There is VERY limited need on the internet for a discrete GPU to be active. It's use should be the exception, and not the rule -- but this is not the case thanks to WebGL.

If I, or any MacBook Pro users, wish to use Firefox 4 or higher and not lose battery efficiency, we must use gfxCardStatus to override which graphic accelerator is currently in use -- but it is at the cost of using OSX's dynamic switching technology. In other words, we must assume manual control over which GPU is active at all times. 

Should also be noted that Google Chrome suffers from this same problem, while Safari (and Firefox 3.x) does not.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 646043
You need to log in before you can comment on or make changes to this bug.