Incorrect encoding used when switching from guided to advanced bug entry form

RESOLVED FIXED

Status

()

RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: nicolas.barbulesco, Assigned: glob)

Tracking

Production

Details

(Reporter)

Description

7 years ago
Camino version 2.0.9 (1.9.0.19 2011091218). Mac OS X 10.6.8.

I go to https://bugzilla.mozilla.org and I submit a new bug. I enter this text :
“Move the tab to a new window” : do not reload the page
In the screen, my entered text appears fine.
In a next screen, I get this Summary field, not very pretty :
see screen photo http://screencast.com/t/R0F9mEnw66z .
This is incorrect. I must get the exact string I had entered.

Please fix that bug(s). In Camino or in Bugzilla ?
Thanks.

Nicolas
That's surely a "bug" in Bugzilla, although I'd argue that something might be broken in the encoding on your end, too, because I've never seen Bugzilla do that with curly quotes that I've entered.
Bugzilla's ability to handle non-ASCII quotes in summaries has been a long-standing issue.

FWIW, it looks correct to me, though; perhaps there's an encoding mismatch on your end?
Assignee: nobody → create-and-change
Component: HTML Form Controls → Creating/Changing Bugs
Product: Camino → Bugzilla
QA Contact: form.controls → default-qa
Summary: Curly quotes : not very pretty → Curly quotes : not very pretty
(Reporter)

Comment 3

7 years ago
Now, similar scenarios, similar problems :

I enter this text :
“Save as…” : ask where to save

I get this Summary field, rather not pretty :
screen photo http://screencast.com/t/UzxgAjG6k

Here is my camino ;-) :
http://screencast.com/t/lKz5pkqFdSh

Nicolas
Summary: Curly quotes : not very pretty → Curly quotes, ellipsis and other jolly characters : not very pretty

Comment 4

7 years ago
(In reply to Smokey Ardisson (back-ish; no bugmail - do not email) from comment #2)
> Bugzilla's ability to handle non-ASCII quotes in summaries has been a
> long-standing issue.

I don't know where this story comes from. Bugzilla supports UTF8 correctly since 3.2, i.e. several years ago.

Anyway, I cannot reproduce using Firefox 7.0.1. Please try with another browser too. I don't think this is an upstream bug, unless being reproducible with another browser. Maybe a bug in the bmo extension.
Assignee: create-and-change → nobody
Component: Creating/Changing Bugs → Extensions
Product: Bugzilla → bugzilla.mozilla.org
QA Contact: default-qa → extensions
Version: unspecified → Current
Duplicate of this bug: 691212
See comment 4 in bug 691212 for a possible explanation and STR. It does indeed sound like there's a bug somewhere in Bugzilla code.

Updated

7 years ago
Summary: Curly quotes, ellipsis and other jolly characters : not very pretty → Mixed ASCII and non-ASCII characters appear to get encoded improperly
this only happens with some sequences, it took quite a bit of trial an error for me to find a broken sequence.

steps to reproduce:

1. visit https://bugzilla.mozilla.org/enter_bug.cgi?format=guided#h=dupes|Camino
2. enter "xx÷√" as a summary
3. click on "find similar issues"
4. click on "switch to the advanced bug entry form"

the summary is encoded with escape() as xx%F7%u221A, which isn't correct.  we should be using encodeURIComponent(), resulting in xx%C3%B7%E2%88%9A, which renders correctly on the advanced bug entry form.
Assignee: nobody → glob
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X → All
Hardware: x86_64 → All
Summary: Mixed ASCII and non-ASCII characters appear to get encoded improperly → Incorrect encoding used when switching from guided to advanced bug entry form
fixed:

Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.0/
modified extensions/GuidedBugEntry/web/js/guided.js
Committed revision 7891.

Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.2/
modified extensions/GuidedBugEntry/web/js/guided.js
Committed revision 7910.

note: the fix won't be visible on bugzilla.mozilla.org until the next code push.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.