id attribute of iframe does not specify a name for the browsing context

RESOLVED INVALID

Status

()

Core
Layout: HTML Frames
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: Wyatt Miler, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:7.0) Gecko/20100101 Firefox/7.0
Build ID: 20110824172139

Steps to reproduce:

<!DOCTYPE html>
<html lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<title>Firefox7 iframe bug test case</title>
<base target="maincontent">
</head>
<body>
<table>
  <tbody>
    <tr>
     <td>
       <a href="content2.html">Content2</a>
     </td>
     <td>
      <iframe id="maincontent" src="content1.html" width="200" height="300"></iframe>
     </td>
    </tr>
  </tbody>
</table>
</body>
</html>



Actual results:

Opens content in new tab/window.


Expected results:

Should have opened content in iframe. Works correctly in WebKit and IE browsers.

Comment 1

6 years ago
Created attachment 564117 [details]
Testcase with name attribute

This test works for me when the attribute name="maincontent" is added. I'll adjust the summary for id specifically.

Updated

6 years ago
Summary: Referencing an iframe target opens in a new tab instead of in the iframe intended. → base target opens in a new tab when the intended iframe only has an id attribute

Updated

6 years ago
Status: UNCONFIRMED → NEW
Component: General → Layout: HTML Frames
Ever confirmed: true
OS: Mac OS X → All
Product: Firefox → Core
QA Contact: general → layout.html-frames
Hardware: x86 → All
Version: 7 Branch → unspecified

Updated

6 years ago
Whiteboard: [parity-webkit][parity-IE][parity-Opera]
Per spec, both in HTML4 and in HTML5, only the 'name' attribute of the iframe names the browsing context in the iframe.  The id does not.  So our behavior here is in fact correct.

Spec link: http://www.whatwg.org/specs/web-apps/current-work/multipage/the-iframe-element.html#attr-iframe-name
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
Whiteboard: [parity-webkit][parity-IE][parity-Opera]
I filed https://bugs.webkit.org/show_bug.cgi?id=69236
Summary: base target opens in a new tab when the intended iframe only has an id attribute → id attribute of iframe does not specify a name for the browsing context
(Reporter)

Comment 4

6 years ago
Ok, thanks, works for me. I blame the spec for being confusing.
You need to log in before you can comment on or make changes to this bug.