Last Comment Bug 691248 - XUL tree items shouldn't pick up relations from XUL tree
: XUL tree items shouldn't pick up relations from XUL tree
Status: RESOLVED FIXED
: access
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla10
Assigned To: alexander :surkov
:
: alexander :surkov
Mentors:
Depends on:
Blocks: rela11y
  Show dependency treegraph
 
Reported: 2011-10-02 22:46 PDT by alexander :surkov
Modified: 2011-10-03 18:53 PDT (History)
1 user (show)
surkov.alexander: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (4.68 KB, patch)
2011-10-02 23:15 PDT, alexander :surkov
tbsaunde+mozbugs: review+
Details | Diff | Splinter Review

Description alexander :surkov 2011-10-02 22:46:53 PDT
They are picked up because tree items and tree accessibles shares the same DOM node.
Comment 1 alexander :surkov 2011-10-02 23:15:57 PDT
Created attachment 564126 [details] [diff] [review]
patch
Comment 2 Trevor Saunders (:tbsaunde) 2011-10-03 02:32:49 PDT
Comment on attachment 564126 [details] [diff] [review]
patch


>   Relation rel;
>     PRInt32 parentIndex;
>   if (!NS_SUCCEEDED(mTreeView->GetParentIndex(mRow, &parentIndex)))
>     return rel;

return Relation(); ?

It looks like you could move the declaration of rel down if not get rid of it all together and just return Relation(mParent) and Relation(treeAcc.Getblah()) if you want
Comment 3 alexander :surkov 2011-10-03 07:31:08 PDT
inbound land with Trevor's comment fixed - https://hg.mozilla.org/integration/mozilla-inbound/rev/b963098e5361
Comment 4 Matt Brubeck (:mbrubeck) 2011-10-03 16:54:36 PDT
https://hg.mozilla.org/mozilla-central/rev/b963098e5361

Note You need to log in before you can comment on or make changes to this bug.