Last Comment Bug 691419 - The command line background graphic should be moved to the devtools directory
: The command line background graphic should be moved to the devtools directory
Status: RESOLVED FIXED
[good first bug][mentor=dao][lang=css]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: All All
: P2 normal (vote)
: Firefox 13
Assigned To: Leonard Camacho [:lcamacho]
:
Mentors:
Depends on:
Blocks: 703275
  Show dependency treegraph
 
Reported: 2011-10-03 11:06 PDT by Joe Walker [:jwalker] (needinfo me or ping on irc)
Modified: 2012-02-07 15:04 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patchV1 (8.31 KB, patch)
2012-02-06 17:23 PST, Leonard Camacho [:lcamacho]
no flags Details | Diff | Review
patchV1 generated with hg diff -g (8.01 KB, patch)
2012-02-06 17:53 PST, Leonard Camacho [:lcamacho]
dao+bmo: review+
Details | Diff | Review

Description Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-10-03 11:06:30 PDT
https://bugzilla.mozilla.org/show_bug.cgi?id=656666#c37
Comment 1 Dave Camp (:dcamp) 2011-10-27 08:46:09 PDT
We're doing developer tool prioritization, filter on 'brontozaur'
to ignore the spam.
Comment 2 Leonard Camacho [:lcamacho] 2012-02-06 12:36:59 PST
this look easy, can I take this bug?
Comment 3 Dão Gottwald [:dao] 2012-02-06 13:19:23 PST
(In reply to leonard.camacho from comment #2)
> this look easy, can I take this bug?

Yep.

You'll find all references to commandline.png here:
http://mxr.mozilla.org/mozilla-central/search?string=commandline.png

You need to 'hg copy' toolkit/themes/winstripe/global/icons/commandline.png to browser/themes/gnomestripe/devtools/commandline.png, then 'hg move' toolkit/themes/winstripe/global/icons/commandline.png to browser/themes/winstripe/devtools/commandline.png and toolkit/themes/pinstripe/global/icons/commandline.png to browser/themes/pinstripe/devtools/commandline.png.

The commandline.png entries in toolkit/themes/winstripe/global/jar.mn and toolkit/themes/pinstripe/global/jar.mn need to be removed and added to browser/themes/winstripe/jar.mn, browser/themes/pinstripe/jar.mn and browser/themes/gnomestripe/jar.mn.

Finally, change all chrome://global/skin/icons/commandline.png references to chrome://browser/skin/devtools/commandline.png.
Comment 4 Leonard Camacho [:lcamacho] 2012-02-06 17:23:03 PST
Created attachment 594871 [details] [diff] [review]
patchV1

First try, @dao I dont know who need to review this, can you help me with that?
Comment 5 Dão Gottwald [:dao] 2012-02-06 17:29:08 PST
Comment on attachment 594871 [details] [diff] [review]
patchV1

The code changes look fine, but something seems to be wrong with how you moved or diffed commandline.png. For instance, I see "Binary file browser/themes/gnomestripe/devtools/commandline.png has changed" but no actual data.

Can you try hg diff -g?
Comment 6 Leonard Camacho [:lcamacho] 2012-02-06 17:37:42 PST
It tells me this about an image

diff --git a/toolkit/themes/winstripe/global/icons/commandline.png b/browser/themes/winstripe/devtools/commandline.png
rename from toolkit/themes/winstripe/global/icons/commandline.png
rename to browser/themes/winstripe/devtools/commandline.png
Comment 7 Dão Gottwald [:dao] 2012-02-06 17:49:44 PST
This looks better. Could you please generate the full patch with -g and attach it here?
Comment 8 Leonard Camacho [:lcamacho] 2012-02-06 17:53:34 PST
Created attachment 594875 [details] [diff] [review]
patchV1 generated with hg diff -g
Comment 9 Dão Gottwald [:dao] 2012-02-06 17:59:28 PST
Comment on attachment 594875 [details] [diff] [review]
patchV1 generated with hg diff -g

I hope this applies the right way (toolkit/themes/pinstripe/global/icons/commandline.png needs to be copied, then moved, the other way around obviously won't work). I'll check this after I got some sleep.
Comment 10 Dão Gottwald [:dao] 2012-02-07 00:51:02 PST
Comment on attachment 594875 [details] [diff] [review]
patchV1 generated with hg diff -g

Works. Thanks for doing this!
Comment 12 Marco Bonardo [::mak] 2012-02-07 01:48:32 PST
looks like the file has not been moved?
Comment 13 Marco Bonardo [::mak] 2012-02-07 01:51:16 PST
or better, for some reason win64 can't find it
Comment 14 Marco Bonardo [::mak] 2012-02-07 01:59:57 PST
I removed the aero icon from jar.mn, that was a leftover
https://hg.mozilla.org/integration/mozilla-inbound/rev/b6bf0037c91f
Comment 15 Leonard Camacho [:lcamacho] 2012-02-07 03:44:04 PST
@mak thanks I didn't see that one

Note You need to log in before you can comment on or make changes to this bug.