All users were logged out of Bugzilla on October 13th, 2018

Option to turn off Message Preview Pane (F8) permanently

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: kyle, Unassigned)

Tracking

7 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [DUPEME])

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.2 (KHTML, like Gecko) Chrome/15.0.874.54 Safari/535.2

Steps to reproduce:

1. Have Message List Page open with Preview Pane turned off.
2. Double-click message
3. Return to Message List page


Actual results:

Preview Pane turned on.


Expected results:

Preview Pane should have stayed off.
In fact, for us NetBook users with tiny little screens (no I don't envy) we can't see anything in the preview pane anyway and it is really a nuisance when it comes up.
There should be a Config Editor option to kill the thing for good for those of use that really can never use it.
(Reporter)

Comment 1

7 years ago
The behavior above isn't consistent, and I think it only happens on first load of Thunderbird or first load of an uncached folder combination.
But the point really is that I would like a switch to say "never again for all folders and circumstances"

Comment 2

7 years ago
What is an uncached folder in your case? Are you using IMAP ?
(Reporter)

Comment 3

7 years ago
I am using IMAP with gmail.

Comment 4

7 years ago
I can't see the problem on FF7, with POP3 accounts and also with News accounts, which are something like "uncached folders".
How did you turn off the Preview pane? After it reappears, do you get any messages in Tools -> Error console?
(Reporter)

Comment 5

7 years ago
By FF7 you mean TB7? That is what I am using, but I am using IMAP with several different accounts.
I use F8 to turn it back off again.  And I didn't know about the Error Console.  Next time it happens I'll look and post back.
But beyond the "buggy" nature of what is happening I think this should be more taken as a feature request.  Anybody with a small screen(read netbooks) can't really use the Preview Pane at all and it just clogs up the entire space and makes the message list unusable until the pane is cleared away.  There should be a way to make it completely disabled or hidden forcefully, never to show up, on screens with 600px vertical resolution or less.  (maybe even if the window is reduced to below that size on a bigger screen)
I'll post back with error log as soon as I can.

Comment 6

7 years ago
Sure, TB7 (I write FF automatically as I usually comment in Firefox bugs).
The Message pane should stay always off. If it doesn't it is a bug. It does stay closed for me, even when jumping from folder to folder, from account to other account, even newsgroups account. Doubleclicking messages and closing them. It does not reappear. Is this a problem only in TB7? Or in which version did it start?
(Reporter)

Comment 7

7 years ago
Can't say when it started. I think I first noticed it in TB3. BTW I'm on Gentoo Linux with an normal download of Thunderbird from the Mozilla website (not a local build).
I'm trying to reproduce myself, but as I said hasn't been consistent for me, but happens every so often, and when it does it seems to happen in clumps, and seems to be triggered on the return from a message(I can see the message list fully when I get back and then renders the preview pane).
How is the logic in the system when returning to the message list tab?  Is there even a spot where that could happen?  Might it be happening by a missing setting, or an event firing that shouldn't?  Do you happen to know what source file I could look into to see the code related to that?  Maybe I can track it down on my side.
(Reporter)

Comment 8

7 years ago
Ok just happened again.
Complete Error Log:
Could not find jar manifest entry 'chrome.manifest'.
Could not read chrome manifest file '/home/uare/.thunderbird/v49gz038.default/extensions/en-CA@dictionaries.addons.mozilla.org/chrome.manifest'.
Could not read chrome manifest file '/home/uare/.thunderbird/v49gz038.default/extensions/fr-moderne@dictionaries.addons.mozilla.org/chrome.manifest'.
Warning: Use of getAttributeNodeNS() is deprecated. Use getAttributeNS() instead.
Source File: chrome://messenger/content/messenger.xul
Line: 0

Comment 9

7 years ago
Unfortunately, those messages don't seem relevant to the problem. They probably appear there directly after TB start. Can you confirm that? Just run TB and see the console.
Component: General → Mail Window Front End
QA Contact: general → front-end
(Reporter)

Comment 10

7 years ago
Yeah, they are there immediately on startup :S

Comment 11

7 years ago
xref 
bug 606450 'Close other tabs' opens unwanted preview pane 
bug 573045 Selecting Option to Hide Message Pane (F8) Will Not Stick After Reboot or Process Termination 
bug 606450 'Close other tabs' opens unwanted preview pane 
bug 677563 Message Pane reappears 
bug 275970 Message Pane on/off should be per folder 
Bug 605359 - Completely remove Message Pane (not just minimize it to the bottom of the Inbox)

( the above are from http://tinyurl.com/6mavnjp  )

Updated

6 years ago
Whiteboard: [DUPEME]

Updated

6 years ago
Duplicate of this bug: 763279

Updated

6 years ago
Duplicate of this bug: 781947
Summary: Option to Turn Off Preview Pane Permenantly → Option to turn off Message Preview Pane (F8) permanently
I cannot reproduce this on WinXP, TB17.0.8, using exact steps of comment 0 on Pop3 inbox or IMAP folder.

For ease of workflow, I'll close this worksforme.

Please do reopen this bug if you are able to reproduce it under any circumstances, and please provide exact details of those circumstances and steps.

Otherwise confirmation of wfm or "verified" wfm would be appreciated.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.