Falling leaves demo regressed, leaves disappear early

RESOLVED DUPLICATE of bug 656875

Status

()

RESOLVED DUPLICATE of bug 656875
7 years ago
7 years ago

People

(Reporter: mattwoodrow, Assigned: Ehsan)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
Regression range: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cb4b93331e4f&tochange=7558f15d824

The leaves are being deleted much earlier than expected.

It looks like we still have the ImageFrames and surrounding BlockFrames, but we never create display items for the missing images.
We usually only have around 4 nsDisplayImages, when there should be close to 30.

It looked like it was bailing out in nsFrame.cpp:1891 (the dirty rect intersection).
(Reporter)

Comment 1

7 years ago
This is fixed by the patch in bug 656875
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 656875
(Assignee)

Updated

7 years ago
Assignee: nobody → ehsan
You need to log in before you can comment on or make changes to this bug.