Internet Keywords: connection timeout -> IK search results

RESOLVED INVALID

Status

--
major
RESOLVED INVALID
18 years ago
10 years ago

People

(Reporter: cgross, Assigned: dougt)

Tracking

Trunk
Future
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; 0.8) Gecko/20010215
BuildID:    2001021508

On our website you have the ability to search for the prices of CD's.  The
default timeout is 10 seconds.  However, you can set it to anything you want. 
In our local tests we set it very often to 120 Seconds.  The browser thinks the
server broke off the connection and then does a search.  The problem is that the
server did not break off the connection.  This does not occur with IE and did
not occur with Mozilla 0.7

Reproducible: Always
Steps to Reproduce:
1.Do a CD search on our site
2.Set the timeout to be 120 seconds
3.Wait for the search window to pop up

Actual Results:  The default search engine(Netscape) was queried for our server.

Expected Results:  It should have waited until the web server returns the results.

Comment 1

18 years ago
updating component.
Assignee: asa → neeti
Status: UNCONFIRMED → NEW
Component: Browser-General → Networking
Ever confirmed: true
QA Contact: doronr → tever

Updated

18 years ago
Target Milestone: --- → Future

Comment 2

18 years ago
mass move, v2.
qa to me.
QA Contact: tever → benc
Observed the same thing on Linux using something around 0.8
I was accessing freenet gateway is way slow. I was unable to reproduce later
either because the problem was fixed or I had all the files I knew of already in
my freenet cache.
I'm unable to test the supplied URL due to another networking bug.

Comment 4

18 years ago
We have a an HTTP timeout of ~120 seconds. I think you are saying that you send
back NO data (not even an HTTP status or header) until 120 seconds later. You
need to find some way of entertaining the client while you search.

Comment 5

17 years ago
http://www0.tredix.com:8080 is refusing connections, so I'm unable to duplicate.
 Recommend INVALID unless the reporter can supply a new URL?

Comment 6

17 years ago
http://www0.tredix.com:8080 has been refusing connections for two months;
marking invalid.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 7

16 years ago
-> URL bar.

After combing through piles of so-called networking bugs, I finally found a
report of this behavior.

I don't think the browser should search (via Internet Keywords) automatically
when a good DNS entry points to a server that is slow. I hope this is not the
current behavior, but that is for the IK QA to work out.
Status: RESOLVED → REOPENED
Component: Networking → URL Bar
QA Contact: benc → claudius
Resolution: INVALID → ---
Summary: Timeout causes browser to search server name → Internet Keywords: Timeout causes browser to search server name
(Assignee)

Comment 8

16 years ago
neeti no longer works on mozilla stuff.
Assignee: neeti → dougt
Status: REOPENED → NEW

Comment 9

16 years ago
This should be marked invalid now, because the event (connection timeout) cannot
happen anymore, per bug 142326 #4. 
Summary: Internet Keywords: Timeout causes browser to search server name → Internet Keywords: connection timeout -> IK search results

Comment 10

13 years ago
INVALID it is then
Status: NEW → RESOLVED
Last Resolved: 17 years ago13 years ago
Resolution: --- → INVALID
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.