Windows are jittery and jerky when maximized or minimized

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: edwardp, Unassigned)

Tracking

7 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:7.0.1) Gecko/20110928 Firefox/7.0.1 SeaMonkey/2.4.1
Build ID: 20110928161145

Steps to reproduce:

The screens/windows with Thunderbird 7.0 and 7.0.1 for Windows (32-bit) are rather jittery and jerky when they are minimized and/or maximized.  

Also, when other applications are running along with TB (e.g. Firefox), the windows with those applications are also jittery/jerky, while TB 7 is running.  Once TB is closed, the problem ceases and all windows maximize/minimize smoothly again.

This problem did not occur with Thunderbird 6.x for Windows.

On-board video is nVIDIA GeForce 6150SE nForce 430 (128 Mb video memory).  CPU is AMD Athlon X2 64-bit dual core, running Windows Vista (32-bit) pre-installed.

Comment 1

7 years ago
Maybe HW acceleration started to work in Thunderbird 7 on your card. Please paste the contents of Graphics section of Help->Troubleshooting info .
(Reporter)

Comment 2

7 years ago
Adapter: DescriptionNVIDIA GeForce 6150SE nForce 430        
Vendor ID: 10de
Device: ID03d0
Adapter: RAM128
Adapter Drivers: nvd3dum nvwgf2um
Driver Version: 7.15.11.8214
Driver Date: 3-8-2009
Direct2D Enabled: Blocked for your graphics driver version. Try updating your graphics driver to version 257.21 or newer. 
DirectWrite Enabled: false (7.0.6002.18409) 
ClearType Parameters: ClearType parameters not found
WebGL Renderer: Blocked for your graphics driver version. Try updating your graphics driver to version 257.21 or newer.
GPU Accelerated Windows: 0/1. Blocked for your graphics driver version. Try updating your graphics driver to version 257.21 or newer.

Comment 3

7 years ago
Then it is not what I said. HW acceleration is still disabled. 
Maybe TB just started to trigger some Windows bug. You could try to update your graphics drivers.

Is Firefox 7 not causing this same problem as Thunderbird?
(Reporter)

Comment 4

7 years ago
I just installed the latest video drivers, the issue is still present.

It does not occur with Firefox 7..
(Reporter)

Comment 5

7 years ago
New driver information (from same TB screen)

Adapter Description: NVIDIA GeForce 6150SE nForce 430
Vendor ID: 10de
Device ID: 03d0
Adapter RAM: 128
Adapter Drivers: nvd3dum
Driver Version: 8.15.11.9038
Driver Date: 7-14-2009
Direct2D Enabled: Blocked for your graphics driver version. Try updating your graphics driver to version 257.21 or newer.
DirectWrite Enabled: false (7.0.6002.18409)
ClearType Parameters: ClearType parameters not found
WebGL Renderer: Blocked for your graphics driver version. Try updating your graphics driver to version 257.21 or newer.
GPU Accelerated Windows: 0/1. Blocked for your graphics driver version. Try updating your graphics driver to version 257.21 or newer.

Comment 6

7 years ago
That doesn't look much newer. Isn't there anything released 2011 available? version above 257.21 ?

Comment 7

7 years ago
How does "257.21" relate to "Driver Version: 8.15.11.9038" anyway?
Those two specifications don't seem to have much in common...

Comment 8

7 years ago
See https://wiki.mozilla.org/Blocklisting/Blocked_Graphics_Drivers , section "On Windows", "Nvidia cards".
(Reporter)

Comment 9

7 years ago
(In reply to aceman from comment #6)
> That doesn't look much newer. Isn't there anything released 2011 available?
> version above 257.21 ?

The driver installer (almost 190 Mb) came directly from nVIDIA's web site, that was the latest one available.
(Reporter)

Comment 10

7 years ago
The computer in question was purchased during November 2009, it's not even two years old.

Comment 11

7 years ago
Thanks, so 8.17.12.5721 (Windows 7) or 06/2010+ are the relevant minimum versions.

edwardp, do you have by any chance a compatibility modus activated for Thunderbird?
Some of those affect display as well and may have an impact on the entire desktop.

Right-click C:\Program Files (x86)\Mozilla Thunderbird\thunderbird.exe > Properties.
In the "Compatibility" tab, make sure that no box is checked for the executable.

Comment 12

7 years ago
(In reply to edwardp from comment #10)
> The computer in question was purchased during November 2009, it's not even
> two years old.

Yes, but the graphics drivers are still evolving and nvidia is releasing updates even for your card. I got this one, when selecting your exact model:
http://www.nvidia.com/object/win7-winvista-32bit-280.26-whql-driver.html
If you need some specific language, just fill the form here:
http://www.nvidia.com/Download/index.aspx?lang=en-us
(Reporter)

Comment 13

7 years ago
Compatibility mode is not checked.  The reference to "nForce 430" threw me off, so what I downloaded, may not have been the correct driver, even though it seems to work.  I have downloaded the 280.26 installer, will try this and report back.
(Reporter)

Comment 14

7 years ago
New drivers now installed, no change in windows behavior, still jittery.

New driver info:

Adapter Description: NVIDIA GeForce 6150SE nForce 430
Vendor ID: 10de
Device ID: 03d0
Adapter RAM: 128
Adapter Drivers: nvd3dum
Driver Version: 8.17.12.8026
Driver Date: 8-3-2011
Direct2D Enabled: false
DirectWrite Enabled: false (7.0.6002.18409)
ClearType Parameters: ClearType parameters not found
WebGL Renderer: Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.686)
GPU Accelerated Windows: 0/1. Blocked for your graphics card because of unresolved driver issues.

Comment 15

7 years ago
Would it be possible for you to temporarily install Thunderbird 6 now and see if it really doesn't have the problem? Maybe something else in your system incidentally changed alongside TB7 update and you don't remember it.
(Reporter)

Comment 16

7 years ago
I can certainly try reinstalling 6 (6.0.2).

With the original drivers that were pre-installed with Vista (listed in Comment 2), this did not occur with Thunderbird 6 or prior versions.  

This started with version 7.0.
(Reporter)

Comment 17

7 years ago
With the current (new) drivers, Thunderbird 6.0.2 also displays the jittery windows.  

With the original pre-installed drivers, 6.0.2 did not have jittery windows.

Comment 18

7 years ago
That is not sure it is due to the drivers. Something else could have changed which we didn't find yet.

Do you wish to rollback the drivers and try the originals with TB 6?
(Reporter)

Comment 19

7 years ago
I'm not sure I can roll them back to the original pre-installed drivers.  

I had uninstalled the originals listed in Comment 2 and they were initially replaced with what is listed in Comment 5, which may have been an incorrect driver - but they were for an "nForce 430" according to nVIDIA's web site.  Those were also uninstalled and replaced with what is listed in Comment 14.

I don't know about Vista, but With XP, you could rollback to the last installed driver, but not beyond that.

But TB 6 worked fine with the original drivers.
(Reporter)

Comment 20

7 years ago
TB is the only application that displays jittery windows, everything else on the PC is fine.

Comment 21

7 years ago
I think Vista also should have the feature to rollback to previous driver (as XP). Or you can just install from the installer you used to get the driver in comment 5. I think those driver were very close to the original one.
(Reporter)

Comment 22

7 years ago
When I uninstalled the latest driver, Vista reverted back to a generic driver of some kind.  

With both that generic driver and now using the drivers in Comment 5, the windows are still jittery with TB 6.0.2.  Note that under the Troubleshooting information, nothing is listed under the "Graphics" section now (with TB 6.0.2).
(Reporter)

Comment 23

7 years ago
Back to the new drivers, "Graphics" information is now shown with TB 7.0.1, but the windows are still jittery.

I have no idea what may have changed, but TB is the ONLY application that displays the jittery windows.  All other applications maximize/minimize the windows smoothly.

Comment 24

7 years ago
For comment 22:
Yes, it is empty here too. It seems Thunderbird 6 could not provide the information and it was implemented only in TB7.

But it looks like the jitter is not caused by the upgrade to TB7 when it now also does in TB6.

Can there be any program that can cause this? Have you installed anything around the time you upgraded to TB7 (2011-10-04)?

If you do not remember, you can install the "nightly tester tools" extension:
https://addons.mozilla.org/sk/thunderbird/addon/nightly-tester-tools/?src=search , then it appears in the Tools menu of Thunderbird. You then use the item "crash me" in the menu. The integrated crash reporter should come up and please submit the crash report. Then go into the folder where thunderbird stores your profile (account settings) (something like c:\users\your name\application data\thunderbird) and there you find folder "crash reports" and inside it a folder submitted. Paste here the names of the files you find there.

This will show us the processes and dlls you have loaded at the time of the crash. (So do not have any private/secret applications running which names you don't wish to make public.)

But first have you tried to start TB in safe mode? (Help -> start with addons disabled)
(Reporter)

Comment 25

7 years ago
Just tried TB in Safe Mode, no change, still jittery.  

But the only difference this time, is that with TB running in Safe Mode, the Firefox and SeaMonkey windows are NOT jittery.  With TB running in "regular mode", all application windows will be jittery, until TB is closed.  On the surface, it would now appear that whatever add-ons are not running with TB in Safe Mode, that causes the other application windows to behave normally, with TB running at the same time.

Aside from the incremental updates to Firefox and SeaMonkey and the graphics drivers, the only other known updates were to Windows itself.

Comment 26

7 years ago
Now that is very strange :)
Can you list the addons you use? They are also listed in the Troubleshooting info.
(Reporter)

Comment 27

7 years ago
If you're referring to the "Extensions" heading, there is nothing listed under it.

Otherwise, there is no heading referencing "add-ons".

Comment 28

7 years ago
So do you have any extensions in TB? See in Tools->Addons->Extensions.
(Reporter)

Comment 29

7 years ago
(In reply to aceman from comment #28)
> So do you have any extensions in TB? See in Tools->Addons->Extensions.

No add-ons of that type installed.

Comment 30

7 years ago
That means Safe mode didn't really disable much. In addition to disabling extensions (which you don't have any) it also disables HW acceleration. But you have that disabled automatically even in normal mode due to your card model. So I don't know what difference Safe mode actually did.

You could try in normal mode, Options->advanced->general->config editor, find layers.acceleration.disabled and toggle it to TRUE. Restart TB.
Component: General → Graphics
Product: Thunderbird → Core
QA Contact: general → thebes
Version: 7 → 7 Branch
(Reporter)

Comment 31

7 years ago
Toggling that didn't change anything, the TB windows were still jittery.

In Comment 25, I mentioned that as long as Thunderbird is running, all other windows regardless of the application, will also be jittery and jerky, until Thunderbird is closed.  

I'm wondering if perhaps there might be something graphics-related that is only specific to Thunderbird, that is causing this, since it's the only application that exhibits this jerky behavior.

Comment 32

7 years ago
Are those other apps jerky also when TB is minimized?

I understand what you say but my view on it is that there is no way an app (TB) should influence other programs/windows. That would be either an OS (Win 7) bug, driver bug or an intentional feature of the OS. I think TB is either mistakenly triggering some feature (like the compatibility in comment 11) or a bug in the graphics driver.

And it is strange that Firefox is not triggering it too, as they have the same basic graphics codebase.

Do you have any antivirus? I have seen something like this when my antivirus mistakenly started an app in a sandbox thinking it could be malware. Then the window resizing got awfully slow.
(Reporter)

Comment 33

7 years ago
The other apps display jerky windows when TB is minimized or maximized, this is on Windows Vista Home Premium. 

I am running Avast anti-virus, but have not tried launching TB with Avast disabled.

Comment 34

7 years ago
Ah OK, Windows Vista.
Good, the antivirus I mention was also Avast :) It was drawing a red border around the sandboxed application window. That was on Win XP. Could you try to disable it temporarily? (Right click on its icon in systray -> disable all shields for 10 minutes. If you don't want to disable all shields, you can try only disable the sandboxing, the tutorial is here: http://www.brighthub.com/computing/smb-security/articles/110854.aspx)
(Reporter)

Comment 35

7 years ago
I disabled all of the shields and launched TB.  No difference, the window was still jittery.

Comment 36

7 years ago
I am not sure the sandboxing is part of any of the shields. Can you look at the page on how to disable it in the Avast configuration?
(Reporter)

Comment 37

7 years ago
I am using the free version of Avast.  In looking at that page, it does not appear that their implementation of it in the free version, will do what needs to be done.

Comment 38

7 years ago
That is fine, I also know only the Free version.
But this image is correct:
http://images.brighthub.com/35/d/35dcae984d80bf50c1eb3cccc39df2212624356d_large.jpg .
Find the Autosandbox there and click Settings. Then tick OFF the "enable autosandbox" option (http://images.brighthub.com/4d/d/4dd5adc3a84f343a26db0384e88df751eea7dfa1_small.jpg).
(Reporter)

Comment 39

7 years ago
No change after unchecking the Sandbox option.  TB windows still the same.

Comment 40

7 years ago
Have you restarted the computer after turning off the sandbox? Just to be sure.
(Reporter)

Comment 41

7 years ago
Yes.  Still the same...
(Reporter)

Comment 42

7 years ago
Maybe this is a clue...  If the Thunderbird window is tiled and it's slightly smaller than full-size (entire screen), the window becomes jittery when it's minimized/maximized.  If the window is made smaller while still tiled, it's not jittery.

I also tried the same with Firefox 7.0.1 and SeaMonkey 2.4.1, both remain not jittery when maximized/minimized.
(Reporter)

Comment 43

7 years ago
I have also tried the 64-bit version of Thunderbird 7.0.1 for 64-bit Linux (Debian) and the same window is not jittery or jerky under Linux.

There is also a new update to the nVIDIA driver for Vista, but I have not yet installed it.  Since the previous version did not resolve this issue, I'm not sure the new update will either, but I will test it.
(Reporter)

Comment 44

7 years ago
I am going to close this as Resolved/Works For Me.  

The new release of the nVIDIA drivers for this chip (285.62) appears to have resolved this issue.  The TB window is no longer jittery or jerkey when min/maximized.  :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME

Comment 45

7 years ago
Good to hear that:) If you see it again, just reopen the bug.
But please post the new drive info from about:support so we know what is the good driver exactly.
You need to log in before you can comment on or make changes to this bug.