Compatibility bump does not compare version numbers correctly, misses addons

RESOLVED FIXED in 6.2.6

Status

addons.mozilla.org Graveyard
Compatibility Tools
P1
normal
RESOLVED FIXED
7 years ago
2 years ago

People

(Reporter: kumar, Assigned: kumar)

Tracking

unspecified
6.2.6
x86
Mac OS X

Details

7.0 -> 8.* is failing again because version sorting is not using the version_int column.  I guess we didn't catch this before because we've never done a bump starting at a point-zero release.  Sigh.

This is roughly the current query running in mysql:

mysql> select count(*) from applications_versions av join appversions max on max.id=av.max where av.application_id=1 and max.version >= '7.0' and max.version < '8.*'; 
+----------+
| count(*) |
+----------+
|      890 | 
+----------+

This is roughly the query we want to run:

mysql> select count(*) from applications_versions av join appversions max on max.id=av.max where av.application_id=1 and max.version_int >= 7000000200100 and max.version_int < 8990000200100;

+----------+
| count(*) |
+----------+
|     3621 | 
+----------+

The problem is that '7.*' is not greater than '7.0'.  Duh.
Assignee: nobody → kumar.mcmillan
Priority: -- → P1
Target Milestone: --- → 6.2.6
Fixed https://github.com/jbalogh/zamboni/commit/a16e20172643f2cf6e1ae9c7fb92c908854cb18a
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.