Mousing Over Panorama Icon or press-hold ctrl+~ should show popup of TabGroups

RESOLVED WONTFIX

Status

Firefox Graveyard
Panorama
--
enhancement
RESOLVED WONTFIX
6 years ago
2 years ago

People

(Reporter: donrhummy, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

Currently there's no way to really see which TabGroup you'll be entering when pressing the shortcut keys (ctrl+~) and opening Panorama is very slow. There should be a quick, easy way to show/switch the groups. The following would make Panorama SUPER useful:

1. If user mouses over Panorama icon, a small popup would show up with a list of the groups (current group highlighted) by name/order. The popup would look a little like: http://lh3.ggpht.com/_S0f-AWxKVdM/S86K1t5efmI/AAAAAAAAMK8/w-48akUXd0Y/panel-download-win7%5B2%5D.png

2. If the user cycles through the groups by using the shortcut keys (ctrl+~), if they press and hold the keys, it'll show that same popup and highlight the next group (and then the next if you press the ~ key again)


Actual results:

Currently, nothing.


Expected results:

1. If user mouses over Panorama icon, a small popup would show up with a list of the groups (current group highlighted) by name/order. The popup would look a little like: http://lh3.ggpht.com/_S0f-AWxKVdM/S86K1t5efmI/AAAAAAAAMK8/w-48akUXd0Y/panel-download-win7%5B2%5D.png

2. If the user cycles through the groups by using the shortcut keys (ctrl+~), if they press and hold the keys, it'll show that same popup and highlight the next group (and then the next if you press the ~ key again)

These two together make Panorama very powerful as they suddenly become efficient to use, whereas now it organizes tasks well but is a bit inefficient.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
(Reporter)

Comment 1

6 years ago
Any progress on this? My groups are becoming very inefficient to use. I have about 10 different groups (needed for all my projects) and it's inefficient to have to click the panorama button every time to find the one I need.
Panorama has been removed from Firefox 45, currently in Beta and scheduled for release on March 7th. As such, I'm closing all existing Panorama bugs.

If you are still using Panorama, you will see a deprecation message in Firefox 44, and when 45 is released your tab group data will be migrated to bookmarks, with a folder for each group. There are also a few addons offering similar functionality.

See https://support.mozilla.org/en-US/kb/tab-groups-removal for more info.

We're removing Panorama because it has extremely low usage (about 0.01% of users), and has a large number of bugs and usability issues. The cost of fixing all those issues is far too high to justify, and so we'll instead be focusing our time and energy on improving other parts of Firefox.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.