Switching from Aurora 8 -> 9 disabled my Personas

RESOLVED INACTIVE

Status

()

Toolkit
Add-ons Manager
RESOLVED INACTIVE
7 years ago
2 months ago

People

(Reporter: fox2mike, Unassigned)

Tracking

9 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
A couple of days back, Aurora went from 8 -> 9. When I was prompted for the 9 update, I did that and restarted. I was then told that my Bugzilla Tweaks add-on will be disabled, because it was incompatible with 9.

I clicked okay and when Aurora started, it came up with the default theme and not with my Persona. 

Upon further checking (about:addons) I see that all except the default are disabled. Now I'd disabled some of these myself, but my current persona was Endless Possibilities by Etsu and that was surely not disabled.

I'll attach a few screenshots.
(Reporter)

Comment 1

7 years ago
Created attachment 564754 [details]
Addons
(Reporter)

Comment 2

7 years ago
Created attachment 564755 [details]
Personas
(Reporter)

Comment 3

7 years ago
After filing the bug, I clicked on Enable and the persona is back and working fine. So I'm curious to see why it was disabled during/after the update. 

Thanks!
I assume you haven't had the extension logging enabled in about:config, or did you? The log would give us a hint what could have happened.
(Reporter)

Comment 5

7 years ago
(In reply to Henrik Skupin (:whimboo) from comment #4)
> I assume you haven't had the extension logging enabled in about:config, or
> did you? The log would give us a hint what could have happened.

I didn't have it enabled. I have it enabled now, but I'm not sure how useful that's going to be :)
Also do you have a link to that Persona, which you can please put into the URL field? Thanks.
(Reporter)

Comment 7

7 years ago
(In reply to Henrik Skupin (:whimboo) from comment #6)
> Also do you have a link to that Persona, which you can please put into the
> URL field? Thanks.

Done.
(Reporter)

Comment 8

7 years ago
As per Henrik's instructions over IRC, I downloaded http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011/09/2011-09-27-04-20-12-mozilla-aurora/firefox-8.0a2.en-US.mac.dmg and restored my profile from the 26 of Sept from backups.

I then was able to reproduce the issue again, when Aurora upgraded from 8.0a2 (2011-09-27) to 9.0a2 (2011-10-04).

The persona was disabled again. Working on figuring out how to get useful logs now.
(Reporter)

Comment 9

7 years ago
I can't get my old profile to log even with extensions.logging.enabled;true. 

I created a new test profile and that works fine, including the bugzilla tweaks addon that was disabled in my old profile, wasn't disabled in the new 8 -> 9 upgrade.
(In reply to Shyam Mani [:fox2mike] from comment #9)
> I can't get my old profile to log even with extensions.logging.enabled;true. 
> 
> I created a new test profile and that works fine, including the bugzilla
> tweaks addon that was disabled in my old profile, wasn't disabled in the new
> 8 -> 9 upgrade.

The log messages should appear in the error console (tools - web developer - error console) after startup of 9.0a2
(In reply to Shyam Mani [:fox2mike] from comment #9)
> I created a new test profile and that works fine, including the bugzilla
> tweaks addon that was disabled in my old profile, wasn't disabled in the new
> 8 -> 9 upgrade.

As talked on IRC I thought you were able to reproduce this issue with the fresh profile. Can you please clarify? If that's the case please upload an archive of it as attachment.
(Reporter)

Comment 12

7 years ago
(In reply to Henrik Skupin (:whimboo) from comment #11)
> As talked on IRC I thought you were able to reproduce this issue with the
> fresh profile. Can you please clarify? If that's the case please upload an
> archive of it as attachment.

Nope. And I knew that would happen :) A Fresh profile magically solves everything.

I'll try again tomorrow. If I can't reproduce it on a fresh profile, I'll update the bug.
Some of our folks saw this on the 7 to 7.0.1 upgrade as well.

Comment 14

2 months ago
Per policy at https://wiki.mozilla.org/Bug_Triage/Projects/Bug_Handling/Bug_Husbandry#Inactive_Bugs. If this bug is not an enhancement request or a bug not present in a supported release of Firefox, then it may be reopened.
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → INACTIVE
You need to log in before you can comment on or make changes to this bug.