Last Comment Bug 692039 - Split up defineProperty into name/element/special forms
: Split up defineProperty into name/element/special forms
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla10
Assigned To: Jeff Walden [:Waldo] (remove +bmo to email)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-05 01:03 PDT by Jeff Walden [:Waldo] (remove +bmo to email)
Modified: 2011-10-20 03:05 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (40.14 KB, patch)
2011-10-05 01:03 PDT, Jeff Walden [:Waldo] (remove +bmo to email)
bhackett1024: review+
Details | Diff | Splinter Review

Description Jeff Walden [:Waldo] (remove +bmo to email) 2011-10-05 01:03:15 PDT
Created attachment 564761 [details] [diff] [review]
Patch

This is much prettier than the previous drear, because lots of code defines specific properties which are known to be names and not elements.  It's also helped that even some of the non-specific ones are variable names, which as identifiers can't be indexes.
Comment 1 Jeff Walden [:Waldo] (remove +bmo to email) 2011-10-19 14:10:40 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/8ee42c873213
Comment 2 Marco Bonardo [::mak] 2011-10-20 03:05:34 PDT
https://hg.mozilla.org/mozilla-central/rev/8ee42c873213

Note You need to log in before you can comment on or make changes to this bug.