What's New page for old releases tells you your version is out of date even if it is up-to-date

RESOLVED FIXED in 3.6

Status

www.mozilla.org
General
--
minor
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: hsivonen, Assigned: sgarrity)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
Steps to reproduce:
 1) Update from Firefox 6.0.1 to 6.0.2
 2) Don't close any tabs.
 3) Update to Firefox 7.0.1

Actual results:
The first update opens a tab for http://www.mozilla.org/en-US/firefox/6.0.2/whatsnew/ . When you update to 7.0.1, that tab stays open. The page still tells you your Firefox is out of date when you load the page in the latest release.

Expected results:
Expected old What's New pages not to say that your Firefox is out of date if you already have the latest Firefox and the latest Firefox is showing the What's New page for an old version.

Comment 1

7 years ago
jlongster, what do you think?
The code in the What's New pages are assuming they newer browsers won't hit them, because that shouldn't happen. Obviously, that assumption is wrong!

That code is pretty old and messy, but we can fix this. I'll set an estimate milestone.
Target Milestone: --- → 4.2

Comment 3

7 years ago
This is bizarre since the 7.0 What's New page is not supposed to trigger when users upgrade to Fx7 per Bug 685727. Might this have changed with the 7.0.1 dot release? Or are users getting to this version of the What's New page through other routes?

Webtrends shows the following traffic figures for the last 30 days en-US:

7.0 What's New: 55,600
7.0.1 What's New: 20,000

(relatively low traffic figures for this page - Fx6 What's New page got 2.7M visits in same timeframe when we were showing the What's New page)

Let's be sure to investigate/clean up messy code. Steven - can you help out here?
Assignee: nobody → steven
(Reporter)

Comment 4

7 years ago
(In reply to Laura Forrest from comment #3)
> This is bizarre since the 7.0 What's New page is not supposed to trigger
> when users upgrade to Fx7 per Bug 685727.

The What's New page for 6.0.2 was triggered by the update to 6.0.2. The update to 7.0.1 didn't close that tab thanks to session restore, so the old What's New page showed up as the first thing after the 7.0.1 update was complete.
(Assignee)

Comment 5

7 years ago
(In reply to James Long (:jlongster) from comment #2)
> The code in the What's New pages are assuming they newer browsers won't hit
> them, because that shouldn't happen. Obviously, that assumption is wrong!

Yeah, we've been copying that code over to each new version for years. It's worth rethinking and refreshing.
(Assignee)

Comment 6

7 years ago
Actually, this isn't the crufty old code I was thinking of. In this case, we simply show all traffic to non-current version whatsnew pages the contents of /firefox/out-of-date/

I suppose we may have to add some browser sniffing to that out-of-date page to make sure you really are out-of-date...
Target Milestone: 4.2 → 4.3

Updated

7 years ago
Target Milestone: 4.3 → 4.4

Comment 7

7 years ago
(In reply to Steven Garrity from comment #6)
> Actually, this isn't the crufty old code I was thinking of. In this case, we
> simply show all traffic to non-current version whatsnew pages the contents
> of /firefox/out-of-date/
> 
> I suppose we may have to add some browser sniffing to that out-of-date page
> to make sure you really are out-of-date...

Steven - Let's proceed as you see fit - It's not clear how big of a problem this really is, so feel free to triage and prioritize accordingly. Thanks!

Updated

7 years ago
Target Milestone: 4.4 → 4.5

Updated

7 years ago
Target Milestone: 4.5 → 4.6

Updated

7 years ago
Target Milestone: 4.6 → 4.7

Updated

7 years ago
Target Milestone: 4.7 → 4.8

Updated

7 years ago
Target Milestone: 4.8 → 4.9

Updated

7 years ago
Target Milestone: 4.9 → 4.10

Updated

7 years ago
Severity: normal → minor
Target Milestone: 4.10 → 4.12

Updated

7 years ago
Target Milestone: 4.12 → 1.0

Updated

7 years ago
Target Milestone: 1.0 → 1.1

Updated

7 years ago
Target Milestone: 1.1 → 1.2

Updated

7 years ago
Target Milestone: 1.2 → 1.3

Updated

7 years ago
Target Milestone: 1.3 → 1.4

Updated

7 years ago
Target Milestone: 1.4 → 1.5

Updated

7 years ago
Target Milestone: 1.5 → Future
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Is this still an issue or can we close this?
Can we aks Raymond to do a quick test? on stage once 752689 is fixed?  I've heard anecdotally that this is still a big annoyance for some users.  

For example, nightly users going to a page shows that its out of date, when it definitely is not.  The use case of course is limited, but I think we should test again, especially since the WN page will be going out again with 13 on June 5th.
(In reply to Laura Mesa [:lmesa] [:lvmesa] from comment #9)
> Can we aks Raymond to do a quick test? on stage once 752689 is fixed?  I've
> heard anecdotally that this is still a big annoyance for some users.  

Sounds good. I added bug#752689 as a dependency.
Depends on: 752689
Target Milestone: Future → 2.7

Updated

6 years ago
Target Milestone: 2.7 → 2.9
Raymond, can you test the use case in comment#9 ? Not sure if this is still an issue.
Keywords: qawanted
Target Milestone: 2.9 → 3.6
This has been fixed by bug 757206. We now look at the User-Agent and redirect people to http://www.mozilla.org/en-US/firefox/update/

The update page actually has a bug, I opened bug 776163 to track this.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Keywords: qawanted
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.