If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Unable to get to usertesting.com from the SF office

RESOLVED WORKSFORME

Status

Infrastructure & Operations
NetOps
RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: mcbmoz, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

6 years ago
Hey there, I haven't been able to reach http://usertesting.com for a few days. They recently had a DDOS attack, but their site is up and running.

I've worked with their support engineers and they think that the problem may be on our end.

This is as far as I could get debugging the problem: http://pastebin.mozilla.org/1346584

Can you help me? I run a lot of tests through that account and not being able to access the data or initiate new tests is a bit frustrating.

Comment 1

6 years ago
I'm unclear how their support engineers could make the determination it is our issue with the traceroutes you provided.  They show the trace leaving our network, to our provider (web-pass), and our provider's provider (cogent), and their provider (spectrumnet.us).  It even gets to one of their devices, vsh35.blueboxgrid.com, before it is dropped. 

What did they see that suggested it is on our side?
(Reporter)

Comment 2

6 years ago
(In reply to Ravi Pina [:ravi] from comment #1)
> I'm unclear how their support engineers could make the determination it is
> our issue with the traceroutes you provided.  They show the trace leaving
> our network, to our provider (web-pass), and our provider's provider
> (cogent), and their provider (spectrumnet.us).  It even gets to one of their
> devices, vsh35.blueboxgrid.com, before it is dropped. 
> 
> What did they see that suggested it is on our side?

Hey Ravi, Actually that's something we tried from SF. Their engineers restarted a script which should refresh any IP addresses that may have been blocked due to a previous DDoS attack.

I've also given them my ip address, in case it's been blocked.

Do you have any ideas why this would be happening for me at the SF office, but no where else?
(Reporter)

Comment 3

6 years ago
Ravi, usertesting.com whitelisted my ip address, so I am able to get over there, but other people seem to be having issues. So, this is technically resolved for me, but is an odd issue that blocks other users in the SF office.

Comment 4

6 years ago
I am in San Francisco right now and not having any issues.

Next time it happens, on your Mac can you open a Terminal.app window and type:

traceroute usertesting.com

and copy the output into this bug?

Comment 5

6 years ago
The office has a single hide NAT for users so if the address in question was white listed it should work for everyone in the office.

No changes were made on our side so them adding us to the whitelist appears to be the fix.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.