print.print_printer setting no longer overrides Windows default printer

RESOLVED DUPLICATE of bug 693181

Status

RESOLVED DUPLICATE of bug 693181
7 years ago
7 years ago

People

(Reporter: gkarasik, Unassigned)

Tracking

({regression})

x86
Windows XP
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; chromeframe/14.0.835.8; .NET CLR 2.0.50727; InfoPath.2; .NET CLR 3.0.04506.648; .NET CLR 3.0.4506.2152; .NET CLR 3.5.21022; .NET CLR 1.1.4322; .NET CLR 3.5.30729; .NET4.0C; .NET4.0E; IPH 1.1.21.4019)

Steps to reproduce:

print


Actual results:

print.print_printer setting is ignored in favor of Windows default setting.


Expected results:

setting print.print_printer to other than Windows default should be honored
Is this different than bug 692181 ?
(Reporter)

Comment 2

7 years ago
No, it is not the same bug, although it is related. With the upgrade to v7, TBird stopped displaying a printer-selection screen. That is the other bug. This bug ignores "print.print_printer" setting.

Incidentally, the other bug is resolved by going into Config Editor and resetting print.always_print_silent, which line is added by TBird 7.
Component: General → Printing
Keywords: regression
Product: Thunderbird → MailNews Core
QA Contact: general → printing

Comment 3

7 years ago
However, this does appear to be the same as bug 693181.  bug 693181, however, occurs because print.print_printer is neither read NOR written.  (I.e., the problem is not only that the value is not read, but also is not written.)  Probably someone with more confidence than me should mark one as a dupe of the other.
I'll dup. We can un-dup if we figure out later that they aren't.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 693181
You need to log in before you can comment on or make changes to this bug.