Closed Bug 692198 Opened 8 years ago Closed 8 years ago

Flash content is not correctly clipped

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 10

People

(Reporter: snorp, Assigned: snorp)

References

Details

Attachments

(1 file, 1 obsolete file)

When scrolling/panning, Flash content is often displayed on top of xul UI.
Assignee: nobody → snorp
Attachment #564945 - Flags: review?(doug.turner)
Blocks: 630007
Attachment #564945 - Flags: review?(doug.turner) → review?(blassey.bugs)
Attachment #564945 - Attachment is obsolete: true
Attachment #564945 - Flags: review?(blassey.bugs)
Comment on attachment 565212 [details] [diff] [review]
Bug 692198 - Make Flash on Android draw to bitmap intead of SurfaceView directly

This patch actually builds.
Attachment #565212 - Flags: review?(blassey.bugs)
Comment on attachment 565212 [details] [diff] [review]
Bug 692198 - Make Flash on Android draw to bitmap intead of SurfaceView directly

Review of attachment 565212 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/plugins/base/android/ANPSurface.cpp
@@ +113,4 @@
>      bitmap->format = kRGBA_8888_ANPBitmapFormat;
>      bitmap->rowBytes = bitmap->width * 4;
> +    targetFormat = gfxASurface::ImageFormatARGB32;
> +    */

get rid of the commented out code

@@ +115,5 @@
> +    targetFormat = gfxASurface::ImageFormatARGB32;
> +    */
> +    
> +    // We actually can't handle this right now because gfxImageSurface
> +    // doesn't support RGBA32.

file a bug to support this
Attachment #565212 - Flags: review?(blassey.bugs) → review+
Test failure appears to be caused by bug 692196, so this can be relanded.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/33160751ee86
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 10
You need to log in before you can comment on or make changes to this bug.