the rendered page shows remainings of the previous page or partly destroyed

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
18 years ago
17 years ago

People

(Reporter: matthew2k, Assigned: kmcclusk)

Tracking

({helpwanted})

Trunk
mozilla1.0
Other
Linux
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.1 i686; en-US; 0.8) Gecko/20010216
BuildID:    2001021609

When you are on a page and surf to a another one, sometimes you see parts of the
previous page on the current rendered one. This usally happens if you use
junkbuster. The banner that junkbuster bans will show parts of the previous page
in Mozilla. Also in certain situations Mozilla over renders in a frame (it keeps
the contents and renders the new contents over that - which makes it unreadable).

Reproducible: Always
Steps to Reproduce:
Surf the net and use junkbuster to ban the banners. That shows up the problem
with the baned banner that shows parts of the previous page. I have not figured
out how to reproduce the "over rendering" bug yet. I will keep looking for that.

Actual Results:  The baned banner has remainings of the previous page or
anything that was over it (if you move a Mozilla window over it, it will keep
remaings of that).

And in the "over rendering" case. The page is rendered over the current page
which makes it unreadable.

Expected Results:  The banner should be clean.

The page should be cleaned before the new one is rendered.
Reporter, have you tried to set the HTTP version to 1.0 in
Preferences/Debug/Networking? Is this bug 38488?
(Reporter)

Comment 2

18 years ago
Thanks, but this cannot be the problem because I am using WWWOffle (proxy) also
which access the Junkbuster. So Junkbuster isn't directly involved by Mozilla -
only WWWOffle. I have read the bug report and that seems like a totally
different problem to me.

Comment 3

18 years ago
I have seen images and parts of the menu and buttons from mozilla in iframes and
 almost always in my bugwalkers top frame. So I can confirm this bug on NT with
the latest builds.

Comment 4

18 years ago
updating component
Assignee: asa → karnaze
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout
Ever confirmed: true
QA Contact: doronr → petersen

Comment 5

18 years ago
I see this bug with build 2001031008 on win98se.  No proxy used at all.

Unfortunately, I can't reproduce it.

I first noticed it after exposing a completely covered mozilla window.  Instead
of showing the correct page (the one in the title and address bar), it showed
the last view of the previous page. (see attachment 1 [details] [diff] [review])

I arrowed down a little and got a 'split' view of the former page and the
correct content of the real page. (attachment 2 [details] [diff] [review])

I minimised and restored the window and everything was OK...until I covered all
or part of mozilla and then brought mozilla to the foreground again.  I got the
partial last page view.

After fooling around with a few menu items, bringing up a few other mozilla
windows like history and javascript console, the problem went away.  I think
once before I did a reload to solve the problem also.

Comment 6

18 years ago
Created attachment 27608 [details]
view of mozilla after exposure (note the incorrect content vs. title/address)

Comment 7

18 years ago
Created attachment 27609 [details]
'split' view after arrowing down a bit on the page

Comment 8

18 years ago
Reassigning to Waqar and moving to m0.9.1
Assignee: karnaze → waqar
Target Milestone: --- → mozilla0.9.1
(Assignee)

Comment 9

18 years ago
Taking this bug
Assignee: waqar → kmcclusk
(Assignee)

Updated

18 years ago
Keywords: helpwanted
Target Milestone: mozilla0.9.1 → mozilla0.9.3

Updated

18 years ago
Target Milestone: mozilla0.9.3 → mozilla0.9.4
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.4 → mozilla0.9.6
(Assignee)

Comment 10

17 years ago
I no longer see the problem described in this bug. I think fixes that when in
several months ago to set the background color on a window during page changes
has fixed the problem. The background is cleared to the background color when it
doesn't have any frames that can render.

Marking WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.6 → mozilla1.0
You need to log in before you can comment on or make changes to this bug.