Last Comment Bug 692281 - Re-license the core source map lib to BSD
: Re-license the core source map lib to BSD
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: J. Ryan Stinnett [:jryans] (use ni?)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-05 14:35 PDT by Nick Fitzgerald [:fitzgen] [⏰PDT; UTC-7]
Modified: 2012-01-14 02:20 PST (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Nick Fitzgerald [:fitzgen] [⏰PDT; UTC-7] 2011-10-05 14:35:34 PDT
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0a2) Gecko/20111003 Firefox/9.0a2
Build ID: 20111003042017
Comment 1 Nick Fitzgerald [:fitzgen] [⏰PDT; UTC-7] 2011-10-05 14:42:16 PDT
This core lib was written to be used within Firefox internals, but also by compressors (like UglifyJS) and X-to-JS compilers (like CoffeeScript). However, many of these projects are MIT/BSD licensed, and the MPL tri-license scares them off (makes it impossible?) from incorporating this code in to their projects.

See also https://github.com/jashkenas/coffee-script/issues/558#issuecomment-2180204
Comment 2 Kevin Dangoor 2011-10-05 18:05:23 PDT
Yes, it would make it a lot messier for those projects. For reference, the source map feature is useless in Firefox unless tools like UglifyJS and CoffeeScript generate the necessary files.
Comment 3 Gervase Markham [:gerv] 2011-10-25 04:17:56 PDT
Can someone quickly lay out the technical aspects of this? I thought source map was a format for storing the "real" line numbers for compressed or 'compiled' JS, not a codebase (although there might be a reference implementation)... What actual code are we hoping that other people will use directly?

Gerv
Comment 4 Panos Astithas [:past] 2011-10-25 05:07:13 PDT
(In reply to Gervase Markham [:gerv] from comment #3)
> Can someone quickly lay out the technical aspects of this? I thought source
> map was a format for storing the "real" line numbers for compressed or
> 'compiled' JS, not a codebase (although there might be a reference
> implementation)... What actual code are we hoping that other people will use
> directly?

This bug is about relicensing the library for parsing and consuming that format. Check out the referenced bug 669999 in the See Also link.
Comment 5 Gervase Markham [:gerv] 2011-10-26 02:48:54 PDT
But aren't UglifyJS and CoffeeScript generating the format, rather than parsing and consuming it?

Perhaps we need to have a chat with the decision-makers in this case, and make sure they understand the situation fully. After all, they can take the code under the MPL terms (so no worries about LGPL or GPL requirements affecting their codebases), just as they might take a library under Apache or under a different-number-of-clause BSD licence. 

Gerv
Comment 6 Nick Fitzgerald [:fitzgen] [⏰PDT; UTC-7] 2011-10-26 10:37:09 PDT
> This bug is about relicensing the library for parsing and consuming that format.

Actually, this core library both consumes *and* generates source maps. There is a bit of code that is shared between both the generation and consumption of source maps, mostly the base 64 stuff.

> But aren't UglifyJS and CoffeeScript generating the format, rather than parsing and consuming it?

Yes, but they would still use this core library unless they reimplemented everything which would be a huge act of wasted effort/duplication, in my opinion.

> Perhaps we need to have a chat with the decision-makers in this case, and make sure they understand the situation fully. After all, they can take the code under the MPL terms (so no worries about LGPL or GPL requirements affecting their codebases), just as they might take a library under Apache or under a different-number-of-clause BSD licence. 

This is a good idea. I don't know too much about licensing, just saw that there were concerns being raised about the difficulty of including our lib because of the licensing. (https://github.com/jashkenas/coffee-script/issues/558#issuecomment-2180204) My motivation is simply to get source maps adopted and put to use :)

_Nick_
Comment 7 Jeremy Ashkenas 2011-10-26 11:03:52 PDT
Chiming in here -- it would be great to get the source-mapping stuff released under an MIT license (ideally) or a BSD license (would be fine). Anything more restrictive will probably prevent it from being integrated directly integrated with the CoffeeScript compiler.
Comment 8 Brendan Eich [:brendan] 2011-10-28 12:22:42 PDT
We're using BSD for new projects like Rust, dom.js, pdf.js. I see no problem using it here.

/be
Comment 9 Nick Fitzgerald [:fitzgen] [⏰PDT; UTC-7] 2011-10-31 17:56:37 PDT
dcamp, can I ask you to review and merge the pull request for this bug?

https://github.com/mozilla/source-map/pull/2
Comment 10 Paul Irish 2011-12-23 04:04:27 PST
As that pull req has landed I think we can FIXED this badboy.
Comment 11 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-01-14 02:20:53 PST
Thanks Paul.

Note You need to log in before you can comment on or make changes to this bug.