write normal email with invitation (ics file) attached

RESOLVED DUPLICATE of bug 433848

Status

Calendar
Lightning Only
RESOLVED DUPLICATE of bug 433848
7 years ago
7 years ago

People

(Reporter: ppr, Unassigned)

Tracking

Lightning 1.0b7

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110930092603

Steps to reproduce:

I want to write normal email (with a subject and text) with a invitation attached (ics file).


Actual results:

In this moment it seems not possible to write a email and add (in attachment) one event of the lighting calendar. 

So I try to export this event in a ics file to add manually this event to my email but it seems not possible to export only one event...

Of course I can send a invitation from lightning (if I add people to a event) but if I do that I can write additional text (text that does not concern this event).



Expected results:

Lightning should allow to select a event and write a email with this event in ics attachement.
Are you looking for a way to attach an event while composing an email, or a way to add a message when inviting attendees using the event dialog? In the latter case, this is bug 433848. In the former case, the mentioned bug needs to be fixed and then we can overlay the compose dialog.

I'm going to mark this bug duplicate, if I totally misunderstood you please undo.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 433848
(Reporter)

Comment 2

7 years ago
Yes it's quite the same than bug 433848. 

Sorry for this

P-S : I see bug 433848 is open since 2008. I hope it isn't a dead bug now...
(Reporter)

Comment 3

7 years ago
(In reply to Philipp Kewisch [:Fallen] from comment #1)
> Are you looking for a way to attach an event while composing an email, or a
> way to add a message when inviting attendees using the event dialog? In the
> latter case, this is bug 433848. In the former case, the mentioned bug needs
> to be fixed and then we can overlay the compose dialog.

It's the second way who interested me first (to add a message when inviting attendees using the event dialog) but like it's not possible yet. So I try this in an other way (to attach an event while composing an normal email) and it don't work neither. 

Lightning should be able to export a event in one ics file so it is another bug. If nobody answer me it's already in work (I don't find bug report about adding the ability to export one event in one ics file) I will create a other bug report avout that in few days.
The problem with just attaching an event to the email is that it needs to be in a specific format to be seen as an invitation. The Content-Type header should also include information about the itip method (i.e REQUEST), otherwise it may be an ics file, but not an invitation.
(Reporter)

Comment 5

7 years ago
(In reply to Philipp Kewisch [:Fallen] from comment #4)
> The problem with just attaching an event to the email is that it needs to be
> in a specific format to be seen as an invitation. The Content-Type header
> should also include information about the itip method (i.e REQUEST),
> otherwise it may be an ics file, but not an invitation.

ok so I don't open a new bug about exporting ics file.
You need to log in before you can comment on or make changes to this bug.