If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

repacker must not update add-ons with modified sdk codebase

RESOLVED DUPLICATE of bug 690824

Status

addons.mozilla.org Graveyard
Add-on Builder
RESOLVED DUPLICATE of bug 690824
6 years ago
3 years ago

People

(Reporter: irakli, Unassigned)

Tracking

Details

See following post from @blackwind on bug 689420

>
> I'm the author of Reload Plus. Just wanted to point out that the version of the
> SDK bundled with my add-on is MODIFIED. I stripped the code that throws the "no > modifiers" exceptions from addon-kit/lib/hotkeys.js and
> api-utils/lib/keyboard/utils.js to work around bug 677785. This is why my
> add-on had its "Upgrade SDK?" flag disabled and why bug 690824 was filed when
> your repacker didn't respect that.
>
> This, though? It's not a bug and can safely be closed.
>
Component: General → Add-on Builder
OS: Mac OS X → All
Product: Add-on SDK → addons.mozilla.org
QA Contact: general → add-on-builder
Hardware: x86 → All
(In reply to Irakli Gozilalishvili [:irakli] [:gozala] from comment #0)
> See following post from @blackwind on bug 689420
> 
> >
> > I'm the author of Reload Plus. Just wanted to point out that the version of the
> > SDK bundled with my add-on is MODIFIED. I stripped the code that throws the "no > modifiers" exceptions from addon-kit/lib/hotkeys.js and
> > api-utils/lib/keyboard/utils.js to work around bug 677785. This is why my
> > add-on had its "Upgrade SDK?" flag disabled and why bug 690824 was filed when
> > your repacker didn't respect that.
> >
> > This, though? It's not a bug and can safely be closed.
> >

We support an "Upgrade SDK" flag? If so, where do we check for the flag so the repacker can skip add-ons that set it to false?
cc:ing Jeff Balogh, who fixed bug 690824 and might be able to answer dbuc's question in comment 1.
Now we check for it when looking for all the files that need to be repacked.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 690824
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.